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ABSTRAK 

 

 

STUDI IN SILICO AKTIVITAS ANTIDIABETES SENYAWA KOMPLEKS 

Zn(II)-FENILALANIN, Zn(II)-TIROSIN DAN PIOGLITAZON 

TERHADAP PROTEIN 4L7F 

 

Oleh 

 

PUJI LESTARINA SINAGA 

 

Diabetes melitus merupakan penyakit metabolik kronis yang ditandai oleh 

peningkatan kadar glukosa darah akibat gangguan produksi maupun sensitivitas 

insulin. Keterbatasan efektivitas dan efek samping terapi konvensional, seperti 

pioglitazon, mendorong pengembangan alternatif berbasis metallotherapy, khususnya 

kompleks logam seng (Zn) dengan ligan asam amino. Penelitian ini bertujuan 

mengevaluasi potensi kompleks Zn(II)-fenilalanin dan Zn(II)-tirosin sebagai kandidat 

antidiabetes melalui pendekatan in silico dengan target protein MAPK8 (PDB ID 

4L7F). 

Metode yang digunakan meliputi analisis farmakokinetik berdasarkan 

Lipinski’s Rule of Five, Pre-ADME, dan Protox, serta uji molecular docking 

menggunakan AutoDock Vina untuk menilai afinitas pengikatan, energi ikatan, RMSD, 

dan interaksi residu aktif. Hasil analisis menunjukkan bahwa kedua senyawa 

memenuhi kriteria Lipinski’s Rule of Five, memiliki absorpsi yang baik, distribus i 

stabil, serta profil toksisitas yang aman. 

Hasil docking menunjukkan bahwa Zn(II)-tirosin memiliki energi ikatan paling 

rendah sebesar -13,00 kkal/mol, diikuti Zn(II)-fenilalanin sebesar -10,00 kkal/mol, 

sedangkan pioglitazon sebagai kontrol memiliki energi -8,7 kkal/mol. Interaksi 

kompleks Zn(II) dengan residu aktif protein lebih kuat dan beragam dibandingkan 

kontrol positif, sehingga meningkatkan kestabilan ikatan. Berdasarkan hasil analis is 

ini, kedua kompleks berpotensi sebagai agen antidiabetes, dengan Zn(II)-tiros in 

menunjukkan aktivitas paling optimal. 

Kata kunci: Diabetes melitus, Molecular docking, Pioglitazon, Protein MAPK8, 
Zn(II)-fenilalanin, Zn(II)-tirosin



 

ABSTRACT 
 

 

IN SILICO STUDY OF ANTIDIABETIC ACTIVITY OF Zn(II)-

PHENYLALANINE, Zn(II)-TYROSINE COMPLEXES AND PIOGLITAZON 

AGAINST 4L7F PROTEIN 
 

 

 

By 

 

PUJI LESTARINA SINAGA 

 

 

Diabetes mellitus is a chronic metabolic disease characterized by elevated blood 
glucose levels due to impaired insulin production and/or sensitivity. The limited 
effectiveness and side effects of conventional therapies, such as pioglitazon, have 

encouraged the development of alternative approaches based on metallotherapy, 
particularly zinc (Zn) complexes with amino acid ligands. This study aims to evaluate 

the potential of Zn(II)-phenylalanine and Zn(II)-tyrosine complexes as antidiabet ic 
candidates through an in silico approach targeting the MAPK8 protein (PDB ID: 
4L7F). The methods include pharmacokinetic analysis based on Lipinski’s Rule of 

Five, Pre-ADME, and Protox, as well as molecular docking using AutoDock Vina to 
assess binding affinity, binding energy, RMSD, and interactions with active site 

residues. The results show that both compounds meet Lipinski’s criteria, exhibit good 
absorption, stable distribution, and a safe toxicity profile. Docking analysis indicates 
that Zn(II)-tyrosine has the lowest binding energy (-13.00 kcal/mol), followed by 

Zn(II)-phenylalanine (-10.00 kcal/mol), while pioglitazon as the control shows -8.7 
kcal/mol. The interactions of Zn(II) complexes with active site residues are stronger 

and more diverse than the control, enhancing binding stability. Therefore, both 
complexes have potential as antidiabetic agents, with Zn(II)-tyrosine demonstrating the 
most optimal activity. 

Keywords: Diabetes mellitus, Molecular docking, Pioglitazon, MAPK8 protein, 
Zn(II)-phenylalanine, Zn(II)-tyrosine
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I. PENDAHULUAN 

 

 

 

1.1. Latar Belakang 

 

 

Diabetes melitus merupakan penyakit kronis yang ditandai dengan peningkatan kadar 

glukosa darah akibat produksi insulin yang tidak mencukupi. Prevalensi diabetes di 

dunia diperkirakan mencapai 11,1% dari populasi dewasa, dengan lebih dari 1 dari 9 

orang berusia 20–79 tahun hidup dengan diabetes, serta angka kematian mencapai 3,4 

juta setiap tahun (IDF, 2025). Prevalensi diabetes di Indonesia meningkat dari 10,7% 

pada tahun 2023 menjadi 11,7% pada tahun 2025 (Kemenkes RI, 2024). Fakta 

tersebut menunjukkan bahwa diabetes merupakan masalah serius yang mendorong 

pengembangan alternatif terapi pengobatan diabetes yang lebih efektif. Penyakit 

diabetes perlu ditangani dengan pengelolaan yang tepat, salah satunya menggunakan 

terapi obat oral, karena mampu meningkatkan sensitivitas tubuh terhadap insulin 

sekaligus menekan produksi glukosa di hati melalui aktivasi reseptor PPAR-γ. 

Penggunaan pioglitazon juga memiliki keterbatasan karena dapat menimbulkan efek 

samping seperti peningkatan berat badan, serta risiko gangguan fungsi hati pada 

penggunaan jangka panjang (Trial et al., 2024). Keterbatasan pada penggunaan obat 

antidiabetes konvensional mendorong pengembangan alternatif terapi lain, salah 

satunya metallotherapy sebagai pendekatan potensial dalam pengobatan diabetes. 

 
Metallotherapy merupakan bentuk terapi baru dalam pengobatan berbagai penyakit, 

seperti kanker, diabetes melitus, kardiovaskular, neurodegeneratif, inflamasi kronis, 

serta penyakit infeksi. Konsep ini memanfaatkan kompleks logam dalam sistem 

biologis yang mampu berinteraksi dengan biomolekul target melalui mekanisme 
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spesifik, seperti penghambatan enzim dan modulasi stres oksidatif. Beberapa ion 

logam yang dilaporkan berpotensi dalam pengelolaan diabetes, baik dalam kondisi in 

vivo maupun in vitro, meliputi mangan, kobalt, kromium, molibdenum, tembaga, 

seng, dan vanadium (Maanvizhi et al., 2014). Di antara logam yang berpotensi dalam 

metallotherapy, kromium dan tembaga telah banyak diteliti sebagai kandidat utama 

dalam metallotherapy. Penelitian Ambarwati et al., (2021) menunjukkan bahwa 

kompleks Cr(III)-aspartat dan Cu(II)-aspartat yang diuji in vivo pada mencit jantan 

(Mus musculus) yang diinduksi aloksan mampu menurunkan kadar glukosa darah 

secara signifikan, yaitu sebesar 74,19% untuk Cr(Asp)₂Cl₂ dan 76,13% untuk 

Cu(Asp)Cl₂. Temuan tersebut menegaskan bahwa selain kromium dan tembaga, 

logam lain juga berperan penting dalam mekanisme pengaturan glukosa darah.  

 
Logam seng (Zn) merupakan logam yang memiliki fungsi fisiologis penting dalam 

tubuh, terutama pada pankreas dan metabolisme insulin. Zn berperan dalam 

meningkatkan sensitivitas insulin, mengatur produksi serta pelepasan insulin, dan 

melindungi tubuh dari komplikasi akibat diabetes (Ahmad et al., 2024). Penelitian 

Yoshikawa et al., (2005) menunjukkan bahwa kompleks Zn(II) dengan ligan amina 

diuji in vivo pada tikus KK-Ay terbukti mampu menurunkan kadar glukosa darah 

serta menurunkan HbA₁c dari 9,6% menjadi 6,5%. Selain itu kompleks Zn(II) dengan 

asam lipoat diuji secara in silico pada enzim Glycogen phosphorylase (2GPA) 

menunjukkan energi ikatan lebih kuat (-9,5 kkal/mol) dibandingkan asam lipoat saja 

(-6,6 kkal/mol). Perbedaan energi ini menegaskan bahwa kompleks Zn(II)-asam 

lipoat berpotensi sebagai penghambat enzim yang berperan dalam peningkatan kadar 

gula darah ( Jumabaev et al., 2023), sehingga logam Zn dapat membantu menurunkan 

kadar glukosa, dan pemilihan jenis asam amino sebagai ligan sangat menentukan 

stabilitas serta aktivitas biologis kompleks yang terbentuk. 

 
Beberapa asam amino berperan merangsang sekresi insulin, meningkatkan 

sensitivitas jaringan, dan menekan glukoneogenesis di hati. Asam amino seperti 

glutamat, glisin, dan sistein merupakan bagian dari Glucose Tolerance Factor (GTF) 

yang berfungsi meningkatkan efektivitas kerja insulin dalam menjaga homeostasis 
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glukosa darah (Mierza dkk., 2023) Insulin mempertahankan keseimbangan glukosa 

melalui peningkatan glukosa pada jaringan otot dan adiposa lewat translokasi GLUT4 

ke membran plasma (Kaunang and Wangko, 2010). Asam amino aromatik seperti 

fenilalanin dan tirosin dilaporkan berhubungan dengan regulasi glukosa, dimana L-

fenilalanin terbukti meningkatkan sekresi insulin, glukagon, serta hormon inkretin 

sehingga menurunkan kadar glukosa postprandial (Mres et al., 2021), sementara 

kadar tirosin yang tinggi dalam sirkulasi berkorelasi dengan resistensi insulin dan 

peningkatan risiko diabetes melitus tipe 2 ( Wurtz et al., 2013). Hubungan antara 

asam amino dan regulasi glukosa ini menegaskan peran enzim pengatur pensinyalan 

insulin, salah satunya adalah Mitogen-activated protein kinase 8 (MAPK8) sebagai 

target penting dalam pengembangan terapi antidiabetes. 

 
Mitogen-activated protein kinase 8 (MAPK8) atau c-Jun N-terminal kinase 1 (JNK1) 

merupakan enzim serine/threonine kinase dari keluarga MAP kinase yang 

mengoordinasi respon seluler terhadap stres serta sitokin inflamasi. Aktivasi JNK1 

secara berlebihan dapat mengganggu jalur pensinyalan insulin sehingga memicu 

resistensi insulin pada penyakit diabetes mellitus (Yan et al., 2024). Para peneliti 

menjadikan MAPK8 sebagai target strategis dalam pengembangan terapi antidiabetes 

guna meningkatkan kembali sensitivitas insulin dalam tubuh melalui desain inhibitor 

yang selektif. Struktur kristal MAPK8 dengan kode PDB 4L7F menunjukkan 

interaksi molekuler yang kuat antara inhibitor AX13587 dengan residu-residu 

spesifik pada situs pengikatan ATP. Senyawa tersebut membentuk ikatan hidrogen 

ganda dengan residu Met111 pada wilayah hinge, ikatan hidrogen dengan Gln117 dan 

Lys55, serta jembatan hidrogen dengan Asn156. Gugus fluorofenil pada ligan 

menempati kantong induced-fit yang melibatkan residu Arg69 dan Glu73 serta 

menunjukkan interaksi hidrofobik dengan Asp169 (Li et al., 2013). Peneliti 

menggunakan uji molecular docking untuk mengevaluasi afinitas pengikatan ligan 

terhadap residu-residu kunci tersebut guna mendesain inhibitor MAPK8 yang 

memiliki potensi dan selektivitas tinggi sebagai kandidat obat antidiabetes. 
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Uji molecular docking digunakan sebagai metode in silico untuk mengevaluasi 

interaksi senyawa kompleks dengan protein target pada tingkat atomik. Metode ini 

lebih dipilih dibandingkan uji in vivo karena memberikan hasil yang lebih cepat, 

efisien, dan hemat biaya serta mampu menggambarkan afinitas ikatan ligan terhadap 

protein. Penelitian  Abdunazarov et al., (2025) melaporkan bahwa kompleks Zn(II) 

berbasis benzothiazole berinteraksi dengan protein target melalui molecular docking 

dan menghasilkan energi ikatan sebesar (−7,33 kkal/mol), yang menunjukkan potensi 

pengikatan kuat dalam mendukung aktivitas antidiabetes. Hal ini menegaskan peran 

pendekatan komputasi dalam menyeleksi dan merancang senyawa kompleks logam 

Zn sebagai kandidat inhibitor, sehingga analisis in silico terhadap interaksi Zn(II) 

dengan MAPK8 menjadi landasan dalam pengembangan terapi antidiabetes. 

 
Berdasarkan uraian di atas, penelitian ini bertujuan mengevaluasi interaksi senyawa 

kompleks Zn(II)-fenilalanin, Zn(II)-tirosin, dan pioglitazon terhadap MAPK8 4L7F 

melalui pendekatan in silico sebagai antidiabetes. Analisis docking molekuler 

digunakan untuk menilai afinitas pengikatan, kestabilan kompleks, skor docking, 

panjang ikatan, nilai Root Mean Square Deviation (RMSD), posisi ligan, residu aktif 

yang berinteraksi, serta visualisasi 2D dan 3D. Analisis studi farmakokinetik dengan 

Lipinski’s Rule of Five, Pre-ADME, dan Protox dilakukan untuk mengetahui 

absorpsi, distribusi, metabolisme, ekskresi, dan toksisitas senyawa kompleks. Hasil 

penelitian diharapkan menjadi dasar ilmiah bagi pengembangan senyawa kompleks 

Zn(II)-fenilalanin, Zn(II)-tirosin dan pioglitazon sebagai kandidat obat antidiabetes 

yang efektif dan aman. 

 
 

1.2. Tujuan Penelitian 

 

 

Tujuan dari penelitian ini adalalah sebagai berikut : 

1. Mendapatkan sifat farmakokinetik senyawa kompleks Zn(II)-fenilalanin, Zn(II)-

tirosin dan pioglitazon sebagai kandidat obat antidiabetes menggunakan program 

Lipinski’s Rule of Five, Pre-ADME, dan Protox.  
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2. Mendapatkan interaksi kompleks Zn(II)-fenilalanin, Zn(II)-tirosin dan 

pioglitazon terhadap protein MAPK8 melalui uji docking molekuler. 

3. Mendapatkan nilai energi ikatan dan interaksi sisi aktif protein MAPK8 dengan 

kompleks Zn(II)-fenilalanin, Zn(II)-tirosin dan pioglitazon. 

 

 
1.3. Manfaat Penelitian 

 

 

Penelitian ini diharapkan dapat memberikan informasi dan data numerik serta visual 

mengenai model interaksi kompleks Zn(II)-fenilalanin, Zn(II)-tirosin dan pioglitazon 

terhadap Mitogen-activated protein kinase (MAPK8) secara molecular docking yang 

akan digunakan untuk melihat afinitas senyawa kompleks tersebut sebagai kandidat 

obat antidiabetes. 



 

II. TINJAUAN PUSTAKA 

 

 

 

2.1. Diabetes Melitus 

 

 

Diabetes melitus (DM) merupakan penyakit metabolik kronis yang ditandai oleh 

hiperglikemia akibat gangguan produksi maupun fungsi insulin. Sekitar 10,5% 

populasi dewasa dunia atau lebih dari 600 juta orang hidup dengan diabetes, dan 

sebagian besar kasus tergolong diabetes tipe 2. Angka tersebut terus meningkat 

sehingga menimbulkan beban kesehatan global yang signifikan (IDF, 2025). DM 

terbagi menjadi dua tipe utama, yaitu tipe 1 dan tipe 2. DM tipe 1 merupakan 

penyakit autoimun yang merusak sel beta pankreas sehingga produksi insulin 

menurun drastis atau bahkan berhenti sama sekali, dan umumnya terjadi pada anak-

anak serta remaja. Sementara itu DM tipe 2 disebabkan oleh resistensi insulin serta 

penurunan produksi insulin secara bertahap, yang erat kaitannya dengan faktor risiko 

seperti obesitas, pola makan tidak sehat, dan kurangnya aktivitas fisik (Nihan et al., 

2024). 

 

Prevalensi diabetes di Indonesia menunjukkan tren yang terus meningkat dan kini 

menjadi salah satu masalah kesehatan masyarakat yang serius. Kemenkes RI, (2024) 

melaporkan bahwa sekitar 10.2% penduduk usia di atas 15 tahun menderita diabetes 

dengan dominasi kasus pada diabetes tipe 2. Kondisi ini mendorong tenaga medis dan 

peneliti untuk menekankan pentingnya upaya deteksi dini serta strategi pengelolaan 

yang lebih menyeluruh, guna menekan risiko komplikasi. Perubahan gaya hidup 

modern seperti konsumsi makanan tinggi gula, rendah serat dan minimnya aktivitas 
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fisik adalah faktor utama yang memperburuk peningkatan kasus (Shawputri et al., 

2024). Dampak diabetes melitus mencakup komplikasi akut dan kronis yang 

signifikan menurunkan kualitas hidup penderitanya. Nefropati, retinopati, neuropati, 

serta penyakit kardiovaskular merupakan komplikasi kronis yang menyebabkan 

peningkatan morbiditas dan mortalitas. Salah satu pendekatan terapeutik yang 

digunakan dalam mengendalikan kadar glukosa darah adalah melalui penghambatan 

enzim α-glukosidase. Enzim ini berperan dalam pemecahan karbohidrat kompleks 

menjadi glukosa di usus halus, dengan menghambat aktivitasnya, penyerapan glukosa 

dapat diperlambat sehingga lonjakan kadar gula darah pasca makan dapat dikurangi. 

Penelitian terkini di Indonesia juga menunjukkan bahwa inhibitor α-glukosidase 

efektif karena mampu menurunkan kadar glukosa darah postprandial serta 

meningkatkan sensitivitas insulin pada pasien diabetes tipe 2 (Abdullah et al., 2025). 

 
 
2.2. Metallotherapy  

 

 

Metallotherapy merupakan strategi pengobatan baru yang memanfaatkan logam dan 

kompleks logam dalam terapi berbagai penyakit termasuk diabetes melitus. 

Kompleks logam memiliki sifat insulin-mimetik dan aktivitas antioksidan yang 

menurunkan kadar glukosa darah, menekan stres oksidatif, serta melindungi sel β 

pankreas dari kerusakan. Logam seperti vanadium, seng, kromium, dan mangan 

menunjukkan efek hipoglikemik melalui peningkatan sensitivitas insulin, stimulasi 

pengambilan glukosa, dan penghambatan gluconeogenesis (Maanvizhi et al., 2014). 

Peran logam sebagai antioksidan sejalan dengan stres oksidatif yang menjadi faktor 

utama progresivitas komplikasi diabetes. Peningkatan kadar radikal bebas akibat 

hiperglikemia mengganggu fungsi seluler, sedangkan logam esensial seperti Zn, Cu, 

Mn, dan Se bersama dengan antioksidan alami menjaga keseimbangan redoks, 

melindungi sel β pankreas, dan menekan komplikasi diabetes (Shafras et al., 2024). 

Kompleks logam Zn dapat digunakan sebagai obat diabetes tipe 2 karena kompleks 
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tersebut mampu meningkatkan produksi insulin sekaligus memperbaiki sensitivitas 

reseptor insulin terhadap glukosa. 

 

2.3. Logam Seng (Zn) 

 

 

Logam seng (Zn) merupakan logam yang berperan dalam metabolisme glukosa dan 

insulin. Seng mendukung sintesis, penyimpanan, kristalisasi, dan sekresi insulin pada 

sel β pankreas serta meningkatkan sensitivitas insulin melalui aktivasi jalur PI3K/Akt 

yang mengatur pengambilan glukosa di jaringan (Fern et al., 2019). logam seng 

bertindak sebagai insulin mimetik karena ion seng mampu menstimulasi oksidasi 

glukosa dan mengaktifkan molekul pensinyalan seperti Akt, GSK-3β, dan p38 pada 

sel otot rangka manusia maupun tikus sehingga menjaga homeostasis glukosa 

(Norouzi et al., 2018). Logam seng berperan dalam pertahanan antioksidan dengan 

menjadi kofaktor enzim superoksida dismutase, menekan stres oksidatif, dan 

melindungi sel dari kerusakan akibat radikal bebas pada diabetes melitus tipe 2 

(Jayanne et al., 2015).  

 
Kompleks seng yang disintesis bersama ligan organik, seperti kompleks Zn(II)-

glukosa-sitrat terbukti memiliki aktivitas antioksidan yang lebih tinggi dan 

bioavailabilitas yang baik sehingga berpotensi digunakan sebagai kandidat 

suplementasi seng dengan efek protektif terhadap metabolisme glukosa (Zhang et al., 

2021). Kompleks Zn(II) dengan ligan asam amino merupakan pendekatan yang 

potensial karena asam amino meningkatkan kestabilan kompleks dan memperkuat 

aktivitas biologisnya. 

 
 

2.4. Fenilalanin 

 

 

Fenilalanin merupakan asam amino aromatik esensial yang berperan dalam 

metabolisme energi, regulasi glukosa, dan sintesis neurotransmiter. Asam amino ini 

penting sebagai penyusun protein dan berperan dalam menjaga keseimbangan 
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metabolisme tubuh. Penelitian Luo et al., (2020) menunjukkan bahwa kadar 

fenilalanin plasma yang rendah bersama tirosin meningkatkan risiko retinopati 

diabetik pada pasien diabetes tipe 2, terutama jika disertai nefropati, sehingga 

metabolisme fenilalanin menjadi faktor penting dalam perkembangan komplikasi 

mikroangiopati. Struktur fenilalanin dapat dilihat pada gambar 1. 

 

 

Gambar 1. Struktur Fenilalanin  

 

Penelitian Zhou et al., (2022) juga melaporkan bahwa peningkatan kadar fenilalanin 

dapat mengganggu pensinyalan insulin melalui modifikasi residu lisin 1057/1079 

pada subunit β reseptor insulin (IRβ) yang dikatalisis oleh fenilalanil-tRNA sintetase 

(FARS). Kondisi ini menyebabkan hambatan translokasi GLUT4, resistensi insulin, 

dan akhirnya memicu gejala diabetes tipe 2, sebagaimana dibuktikan pada model 

hewan dengan diet tinggi fenilalanin maupun aspartam. Fenilalanin dengan tirosin 

tidak hanya berperan sebagai prekursor neurotransmiter, tetapi juga berfungsi sebagai 

penanda metabolik penting yang memengaruhi homeostasis glukosa dan risiko 

komplikasi diabetes. 

 

 

2.5.  Tirosin 

 

 

Tirosin adalah salah satu asam amino aromatik yang berperan penting dalam 

metabolisme tubuh dan regulasi sinyal seluler. Asam amino tirosin berperan dalam 

regulasi metabolisme glukosa dan sensitivitas insulin. Penelitian Hatakawa et al., 

(2024) menunjukkan bahwa modifikasi residu tirosin pada enzim insulin-degrading 

enzyme (IDE) mampu mengubah spesifisitas substratnya. Modifikasi ini membuat 
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IDE tetap mendegradasi amyloid beta (Aβ) tetapi tidak merusak insulin, sehingga 

kadar insulin tetap terjaga. Mekanisme ini berpotensi mengurangi risiko diabetes 

melitus tipe 2 sekaligus memberikan manfaat terapeutik pada penyakit 

neurodegeneratif. Struktur tirosin dapat dilihat pada gambar 2. 

 

 
Gambar 2. Struktur Tirosin (Ding et al., 2023) 

 
 

Tirosin juga berperan dalam mekanisme sinyal insulin. Asam amino ini dapat 

meningkatkan regulasi transport glukosa dan memengaruhi jalur glukoneogenesis. 

Dalam kondisi terkontrol, tirosin membantu mempertahankan homeostasis glukosa 

dan mendukung fungsi sel β pankreas (Ding et al., 2023). Dengan demikian, tirosin 

berpotensi dimanfaatkan sebagai biomolekul yang mendukung terapi antidiabetes 

melalui pengaturan aktivitas enzimatik dan peningkatan sensitivitas insulin. 

 

 

2.6. Pioglitazon 

 

 

Pioglitazon merupakan salah satu obat golongan thiazolidinedione yang digunakan 

dalam terapi diabetes melitus tipe 2 dan terbukti efektif meningkatkan sensitivitas 

insulin tanpa menimbulkan risiko hipoglikemia yang tinggi. Pioglitazon memiliki 

nama IUPAC (RS)-5-(4-[2-(5-ethylpyridin-2-yl)ethoxy]benzyl)thiazolidine-2,4-dione. 

Struktur kimia Pioglitazon mengandung beberapa gugus fungsi penting, yaitu gugus 

thiazolidinedione, cincin piridin, gugus eter, dan cincin aromatik benzena. Gugus 

thiazolidinedione berperan sebagai gugus utama yang memberikan aktivitas 

antidiabetes karena gugus tersebut mampu berikatan dengan reseptor peroxisome 

proliferator-activated receptor gamma (PPAR-γ). Aktivasi reseptor PPAR-γ 
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meregulasi transkripsi gen-gen yang berperan dalam metabolisme glukosa dan lipid 

sehingga meningkatkan sensitivitas insulin pada jaringan perifer. Mekanisme tersebut 

menyebabkan Pioglitazon mampu menurunkan kadar HbA1c secara signifikan serta 

memberikan efek perlindungan sekunder terhadap kejadian makrovaskular, seperti 

infark miokard dan stroke (Dormandy et al., 2005). 

 

Penggunaan Pioglitazon dalam jangka panjang telah dibuktikan oleh berbagai 

penelitian klinis yang menunjukkan bahwa obat ini dapat memperbaiki fungsi sel beta 

pankreas dan menurunkan resistensi insulin perifer (Trial et al., 2024). Pioglitazon 

dapat digunakan secara tunggal maupun dikombinasikan dengan obat lain, seperti 

metformin dan dapagliflozin, untuk mencapai target pengendalian glikemik yang 

lebih optimal pada pasien yang tidak terkontrol dengan terapi standar. Pioglitazon 

menjadi pilihan obat oral yang penting dalam pengelolaan diabetes melitus tipe 2 

karena efektivitasnya dalam memperbaiki profil lipid dan mengurangi peradangan 

sistemik. Struktur Pioglitazon dapat dilihat pada Gambar 3 

 

 

Gambar 3. Struktur Pioglitazon 

(https://pubchem.ncbi.nlm.nih.gov/compound/Pioglitazon) 

 

Pengembangan kandidat obat antidiabetes memerlukan penentuan farmakokinetik 

untuk menilai bioavailabilitas, metabolisme, distribusi, ekskresi, serta profil toksisitas 

senyawa. Peneliti melakukan evaluasi tersebut agar efektivitas dan keamanan yang 

sebanding dengan Pioglitazon dapat dicapai dalam desain obat baru 

 

 

 

 

https://pubchem.ncbi.nlm.nih.gov/compound/Pioglitazone
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2.7. Penentuan Farmakokinetik Obat 

 

 

Penentuan farmakokinetik obat memberikan gambaran awal tentang efektivitas dan 

keamanan senyawa dalam tubuh. Kajian ini menilai bioavailabilitas, absorpsi, 

distribusi, metabolisme, ekskresi, dan potensi toksisitas sebagai dasar pengembangan 

terapi berbagai penyakit. Penentuan farmakokinetik dalam penyakit kronis seperti 

diabetes mellitus membantu pemilihan kandidat obat yang efektif menurunkan kadar 

glukosa darah dan aman untuk penggunaan jangka panjang. Kajian ini dilakukan 

melalui Lipinski’s Rule of Five sebagai acuan kelayakan fisikokimia, melalui  

Pre-ADME untuk mengevaluasi sifat farmakokinetik, serta melalui analisis toksisitas 

untuk memastikan keamanan senyawa sebagai kandidat obat antidiabetes. 

 

 

2.7.1. Lipinski’s Rule Of Five 

 

 

Lipinski’s Rule of Five merupakan pedoman penting dalam bidang penemuan obat 

yang digunakan untuk menilai druggability atau kelayakan suatu senyawa kimia 

sebagai kandidat obat. Aturan ini berfungsi untuk memprediksi kemungkinan 

aktivitas oral suatu molekul berdasarkan sifat fisikokimianya (Nhlapho and Munien, 

2024). Dalam penelitian farmasi modern, penerapan Lipinski’s Rule of Five 

membantu peneliti mengidentifikasi senyawa yang memiliki potensi bioavailabilitas 

baik serta mampu menembus membran biologis dan berinteraksi dengan target 

reseptor secara efektif. 

Menurut Lipinski, senyawa dikatakan memiliki sifat obat yang baik apabila tidak 

melanggar lebih dari satu dari lima kriteria utama, yaitu:  

a. memiliki berat molekul kurang dari 500 Dalton, 

b. memiliki nilai logP tidak lebih dari 5,  

c. memiliki tidak lebih dari 5 donor ikatan hidrogen (HBD), 

d. memiliki tidak lebih dari 10 akseptor ikatan hidrogen (HBA), 
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e. mempertimbangkan faktor tambahan seperti jumlah ikatan rotasi serta luas 

permukaan polar (Polar Surface Area, PSA).  

Senyawa yang memenuhi kriteria tersebut umumnya menunjukkan kemampuan 

penetrasi membran yang baik serta memiliki stabilitas yang mendukung absorpsi oral. 

Lipinski’s Rule of Five menjadi panduan utama dalam proses penyaringan awal 

(virtual screening) pada penemuan obat. Aturan ini memberikan kerangka yang jelas 

untuk menilai kelayakan molekul secara cepat dan efisien, sehingga membantu 

mempercepat proses seleksi senyawa dengan potensi bioavailabilitas tinggi dan 

meningkatkan peluang keberhasilan dalam pengembangan obat baru (Benet et al., 

2017).  

 
 

2.7.2. Pre-ADME 

 

 

Pre-ADME merupakan metode komputasi yang digunakan untuk memperkirakan 

sifat farmakokinetik suatu senyawa, yang mencakup kemampuan absorpsi, distribusi, 

metabolisme, dan ekskresi (ADME) sebelum dilakukan pengujian secara 

eksperimental. Menurut Nusantoro dan Fadlan, (2021) analisis ini menggunakan 

perangkat lunak Pre-ADME dan SwissADME untuk menilai sejauh mana suatu 

senyawa berpotensi menjadi kandidat obat yang efektif. Melalui metode ini, berbagai 

parameter penting dapat diprediksi, seperti Human Intestinal Absorption (HIA) untuk 

menilai kemampuan senyawa diserap melalui dinding usus, Human Oral 

Bioavailability (HOB) untuk memperkirakan tingkat ketersediaan hayati oral, Blood-

Brain Barrier (BBB) untuk mengevaluasi kemampuan senyawa menembus sawar 

darah otak, Plasma Protein Binding (PPB) yang menggambarkan fraksi obat dalam 

bentuk terikat maupun bebas di dalam plasma darah, serta Caco-2 cell permeability 

yang digunakan sebagai model in vitro yang merepresentasikan penyerapan senyawa 

melalui epitel usus manusia. 

 



  14 

2.7.3. Toksisitas 

 

Uji toksisitas adalah pengujian yang bertujuan untuk menilai potensi berbahaya suatu 

senyawa terhadap organisme hidup, sehingga dapat menentukan keamanan senyawa 

tersebut sebelum dijadikan kandidat obat. Pengujian ini penting untuk meminimalkan 

risiko efek samping atau kerusakan pada organ tubuh. Dalam penelitian modern, uji 

toksisitas dapat dilakukan secara in silico menggunakan perangkat lunak Protox. 

Software ini memberikan prediksi mengenai klasifikasi toksisitas senyawa serta 

potensi efek negatif spesifik, termasuk hepatotoksisitas, karsinogenisitas, 

imunitoksisitas, mutagenisitas, dan sitotoksisitas (Nursanti et al., 2023). Metode ini 

membantu peneliti menilai keamanan kandidat obat secara cepat dan efisien sebelum 

melakukan uji laboratorium lebih lanjut. Kemudian dilakukan molecular modeling 

untuk memberikan gambaran interaksi senyawa dengan target protein untuk 

menjelaskan mekanisme kerja obat secara lebih mendalam. 

 
 

2.8. Molecular Modelling  

 

 

Molecular modeling adalah teknik yang digunakan untuk merancang dan 

menampilkan struktur serta sifat molekul dengan memanfaatkan metode kimia 

komputasional dan visualisasi grafis. Teknik ini mencakup visualisasi struktur secara 

otomatis, analisis tiga dimensi dari basis data, konstruksi struktur protein berdasarkan 

urutan homolog, dan docking ligan. Molecular modeling menekankan perhitungan 

energi konformasi dan interaksi molekul, yang dapat dihitung melalui mekanika 

kuantum maupun fungsi empiris energi (Teodoro et al., 2001). 

 

Molecular modeling memiliki tiga aplikasi utama, yaitu analisis struktur dan sifat, 

homology modeling, dan molecular docking. Tujuan penggunaan teknik ini adalah 

menghasilkan struktur geometri tiga dimensi yang sesuai dengan parameter kondisi 

yang ditentukan (Wade, 2019). Molecular modeling menggunakan force fields 

sebagai fungsi empiris energi potensial protein yang dikembangkan melalui 
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kombinasi interaksi ikatan (jarak, sudut, dan torsi) serta interaksi non-ikatan seperti 

gaya Van der Waals dan elektrostatik (Teodoro et al., 2001). Molecular modeling 

menjadi dasar penting bagi pengembangan metode komputasi lanjut dan molecular 

docking digunakan secara khusus untuk mengevaluasi afinitas dan orientasi ligan 

ketika berikatan dengan protein target. 

 

 

2.9. Molecular Docking 

 

Molecular Docking merupakan pendekatan komputasi fundamental yang digunakan 

untuk memodelkan kompleks struktural dan memprediksi energi pengikatan yang 

dihasilkan dari interaksi antara ligan dan reseptor (Meng et al., 2012). Teknik ini 

penting dalam penemuan obat dengan bantuan komputer karena menawarkan 

keuntungan berupa efisiensi waktu dan biaya yang rendah (More et al., 2024). Pada 

prosesnya docking melibatkan algoritma pengambilan sampel untuk mencari 

konformasi optimal dan fungsi penilaian untuk menilai afinitas pengikatan ( Meng et 

al., 2012).  

 

Parameter keberhasilan molecular docking meliputi energi ikatan (binding energy), 

nilai Root Mean Square Deviation (RMSD), residu asam amino pada sisi aktif 

protein, serta panjang ikatan yang terbentuk antara ligan dan residu sisi aktif. Energi 

ikatan menunjukkan kestabilan kompleks ligan–reseptor, di mana semakin negatif 

nilai energi ikatan maka semakin kuat dan stabil interaksi yang terbentuk. Nilai 

RMSD digunakan untuk menilai tingkat kesesuaian posisi ligan hasil docking 

terhadap konformasi referensi, dengan nilai RMSD ≤ 2 Å yang umumnya 

menunjukkan hasil docking valid dan akurat. Residu asam amino pada sisi aktif 

protein berperan dalam pembentukan berbagai jenis interaksi, seperti ikatan hidrogen, 

interaksi hidrofobik, dan interaksi elektrostatik yang menentukan spesifisitas serta 

kekuatan pengikatan ligan terhadap reseptor. Panjang ikatan antara ligan dan residu 

sisi aktif protein juga memengaruhi kestabilan interaksi, terutama pada ikatan 
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hidrogen yang umumnya memiliki panjang sekitar 2–3.5 Å sehingga menunjukkan 

interaksi yang lebih kuat dan stabil. 

 

Penelitian Sayed et al., (2024) menunjukkan bahwa nanomaterial Cu-doped ZnO 

melalui simulasi molecular docking dengan enzim α-amilase memiliki potensi 

aktivitas anti-diabetes dan anti-mikroba yang kuat. Hasil docking ini divalidasi 

dengan nilai energi ikat negatif yang signifikan, menunjukkan afinitas pengikatan 

yang kuat antara nanomaterial tersebut dengan sisi aktif enzim α-amilase dan protein 

target mikroba, sehingga mendukung temuan aktivitas biologis yang diamati secara in 

vitro. Protein target berperan sebagai reseptor utama yang menjadi pusat interaksi 

ligan dalam proses docking, sehingga pemahaman mekanisme interaksi ini sangat 

penting untuk mengarahkan desain obat yang lebih spesifik. 

 

 

2.10. Protein Data Bank (PDB) 

 

 

Protein Data Bank (PDB) merupakan salah satu sumber biodata akses terbuka yang 

paling banyak digunakan di seluruh dunia. PDB telah terakreditasi oleh 

CoreTrustSeal dan digunakan oleh jutaan peneliti dasar maupun terapan, pendidik, 

hingga mahasiswa karena hampir 200.000 struktur tiga dimensi (3D) makromolekul 

biologis seperti protein, asam nukleat, dan karbohidrat telah diarsipkan secara 

konsisten, divalidasi secara ketat, serta diuji secara eksperimental (Burley et al., 

2021). Akses terbuka ke data PDB tanpa batasan penggunaan juga memungkinkan 

bioinformatika struktural berkembang sebagai sub-disiplin biologi komputasi yang 

dinamis. Pemodelan struktur protein homologi atau komparatif bergantung pada 

penggunaan struktur yang ditentukan secara eksperimental dengan urutan asam amino 

sebagai template pemodelan (John and Sali, 2003). 

 

Jenis protein yang digunakan pada penelitian ini adalah Mitogen-activated protein 

kinase 8 (MAPK8) dengan kode PDB 4L7F yang diunduh dari website 

(www.rcsb.org) dengan detail struktur sebagai berikut: 

http://www.rcsb.org/
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Berat Molekul Teoritis : 21,7 kDa 

Sistem Ekspresi  : Escherichia coli  

Kode Canonical  : P45983 

Nama Gen   : MAPK8  

Resolution   : 1,95 Å 
 
Ligands   : O-Phosphotyrosine (C26H26FN5O2) 

 
Organism(s)   : Homo sapiens 

 
Gambar 4. MAPK8 4L7F ( https://www.rcsb.org/structure/4L7F )  

 

 

 

2.11. Ligan 

 

 

Ligan merupakan molekul atau ion yang memiliki atom donor dan mampu 

mendonorkan pasangan elektron bebas ke atom pusat logam melalui ikatan kovalen 

koordinasi, sehingga berperan sebagai basa Lewis dalam pembentukan senyawa 

kompleks (Budi, 2020). Senyawa kompleks terbentuk ketika logam transisi sebagai 

asam Lewis menerima elektron dari satu atau lebih ligan dengan konfigurasi geometri 

tertentu yang menentukan sifat kimia maupun aplikasinya. Ligan dalam biokimia 

mencakup molekul kecil yang berikatan dengan reseptor protein dan memicu 

https://www.rcsb.org/structure/4L7F
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perubahan konformasi serta aktivitas reseptor sehingga menghasilkan respons 

biologis spesifik. Ligan juga berfungsi sebagai penghubung sinyal seluler dengan 

menempel pada protein target melalui ikatan hidrogen, ikatan ion, maupun gaya Van 

der Waals yang kemudian diteruskan ke dalam sel melalui jalur pensinyalan 

intraseluler. Molecular docking digunakan untuk memprediksi interaksi ligan dengan 

protein target serta menentukan konformasi ikatan yang paling stabil (Setiawan et al., 

2017). Penempatan ligan pada situs aktif protein menentukan efektivitas pengikatan, 

kestabilan kompleks, dan respons biologis yang dihasilkan. 



 

III. METODE PENELITIAN 

 

 

 

3.1. Waktu dan Tempat 

 

 

Penelitian ini telah dilaksanakan pada bulan Oktober 2025 sampai dengan Februari 

2026, bertempat di jurusan Kimia, FMIPA Universitas Lampung. 

 
 

3.2. Alat dan Bahan 

 

 

Alat-alat yang digunakan dalam penelitian ini adalah perangkat keras dan perangkat 

lunak. Perangkat keras yang digunakan adalah Laptop ASUS ExpertBook 

P1411CMA dengan prosesor Intel Celeron N4020, RAM 4.00 GB DDR4, dan 

Windows 10 64-bit Operating System. Perangkat lunak yang digunakan adalah 

Autodock-Tools 1.5.7, Discovery Studio Visualization, Autodock vina, Pymol, dan 

Command Prompt. 

 

Bahan-bahan yang digunakan adalah struktur 3D dari protein target 4L7F yang 

diperoleh dari website RSCB PDB, struktur 3D senyawa kompleks Zn(II)-

Fenilalanin, Zn(II)-Tirosin dan Pioglitazon. 
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3.3. Prosedur Penelitian 

 

3.3.1.  Penentuan Farmakokinetik 

 

Penentuan farmakokinetik dilakukan dengan memanfaatkan beberapa situs daring, 

yaitu Lipinski Rule of Five, PreADME, dan Protox untuk memprediksi potensi 

kandidat obat dari ligan hasil simulasi docking. 

 

3.3.1.1. Lipinski’s Rule of Five 

 
Proses dilakukan dengan mengakses laman www.scfbio-

iitd.res.in/software/drugdesign/lipinski.jsp. Pada situs ini, file ligan dalam format .pdb 

diunggah, kemudian diklik submit untuk mendapatkan hasil analisis berdasarkan 

aturan Lipinski, yang menilai kelayakan senyawa sebagai obat oral. 

 

 
3.3.1.2. Pre-ADME 

 

Proses dilakukan dengan membuka laman https://preadmet.webservice.bmdrc.org/. 

Pada laman tersebut dipilih menu ADME Prediction, kemudian struktur 2D dari ligan 

yang akan dianalisis digambar menggunakan aplikasi bawaan situs. Proses 

penggambaran dilanjutkan dengan menekan tombol Submit untuk memperoleh data 

prediksi absorpsi, distribusi, metabolisme, dan ekskresi dari senyawa uji. 

 

 

3.3.1.3. Protox 

 

Prosedur dilakukan dengan mengunjungi situs www.tox-new.charite.de/protox_II/. 

Pada situs tersebut dipilih menu Tox Prediction, kemudian nama senyawa yang akan 

dianalisis dimasukkan pada kolom yang tersedia. Proses dilanjutkan dengan menekan 

tombol run untuk memperoleh hasil prediksi toksisitas, meliputi tingkat keamanan 

serta potensi efek samping dari senyawa tersebut. 

 

 
 

http://www.scfbio-iitd.res.in/software/drugdesign/lipinski.jsp
http://www.scfbio-iitd.res.in/software/drugdesign/lipinski.jsp
https://preadmet.webservice.bmdrc.org/
https://tox-new.charite.de/protox_II/
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3.3.2. Pemilihan Protein Target 

 

 
Penentuan protein target dalam penelitian ini dilakukan melalui analisis 

menggunakan website SwissTargetPrediction (https://swisstargetprediction.ch/) dan 

STRING-DB (https://string-db.org/). Kedua situs tersebut digunakan untuk 

mengidentifikasi serta mengevaluasi potensi keterlibatan protein dalam mekanisme 

biologis yang berkaitan dengan penyakit. Berdasarkan hasil analisis jaringan interaksi 

protein yang diperoleh dari STRING-DB, dipilih protein MAPK8 dengan kode PDB 

4L7F sebagai target penelitian karena protein ini memiliki peran penting sebagai 

salah satu target molekuler dalam mekanisme resistensi insulin. 

 
 

3.3.3. Preparasi Protein 4L7F 

 

Kompleks protein 4L7F dipisahkan dari ligan menggunakan Discovery Studio 

Visualizer (DSV) yang dapat dilihat pada lampiran 1 gambar 24, kemudian dilakukan 

optimasi melalui penambahan atom hidrogen dan proses minimisasi energi. Struktur 

hasil optimasi disimpan dalam format berkas (pdb). 

 

Langkah-langkah penelitian ini adalah sebagai berikut: 

 

A. Pembuatan Folder Kerja 

 

Folder kerja baru dibuat pada Documents > VALIDASI 4L7F, kemudian folder 

tersebut diisi dengan software dan berkas yang diperlukan, yaitu 4L7F.pdb, dan 

config. 

 

B. Preparasi Reseptor 4L7F 

 

Preparasi dilakukan menggunakan software DSV 2025. Pada DSV dimasukkan 

berkas protein 4L7F.pdb melalui menu (File > Open), lalu dipilih file 4L7F.pdb yang 

terdapat pada folder kerja dan dikonfirmasi dengan menekan tombol OK. Protein 

yang telah terbuka pada DSV divisualisasikan melalui (Script > Visualization > 

https://swisstargetprediction.ch/
https://string-db.org/
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Publication Quality), kemudian dilakukan preparasi reseptor dengan menghapus 

molekul air menggunakan (Script > Selection > Delete). Ligan dihapus melalui 

(Script > Selection > Select Ligand > Delete) sehingga hanya tersisa reseptor dari 

protein 4L7F. Hasil preparasi disimpan sebagai Reseptor 4L7F.pdb pada folder kerja 

melalui menu (File > Save As > Reseptor 4L7F.pdb). 

 

 
C. Preparasi Ligan 4L7F 

 

Preparasi reseptor protein 4L7F yang telah selesai diikuti dengan pembersihan layar 

kerja melalui menu (Edit > Select All > Delete). Berkas 4L7F.pdb dibuka kembali 

melalui (File > Open) dengan memilih file pada folder kerja dan menekan tombol 

OK. Protein yang tampil pada DSV divisualisasikan menggunakan (Script > 

Visualization > Publication Quality), lalu dilakukan preparasi ligan dengan 

menghapus molekul air melalui (Script > Selection > Delete). Tahapan selanjutnya 

yaitu menghapus rantai protein menggunakan (Script > Selection > Select Protein 

Chain > Delete) sehingga hanya tersisa ligan dari protein 4L7F. Hasil preparasi 

disimpan sebagai Ligan 4L7F.pdb pada folder kerja melalui menu (File > Save As > 

Ligan 4L7F.pdb). 

 

 

3.3.4. Preparasi Ligan 

 

 

Ligan yang digunakan pada penelitian ini terdiri atas [Zn(phe)₂], [Zn(tyr)₂], dan 

pioglitazon. Struktur dua dimensi dari masing-masing ligan digambar menggunakan 

software Avogadro yang dilihat pada lampiran 1 gambar 20, kemudian disimpan 

dalam format .pdb. Pembuatan struktur dilakukan dengan membuka aplikasi 

Avogadro dan menggambar senyawa kompleks [Zn(phe)₂], [Zn(tyr)₂], serta 

pioglitazon. Proses dilanjutkan dengan melakukan optimasi melalui menu (Extension 

> Optimize Geometry) hingga posisi molekul mencapai kestabilan dan tidak 

mengalami rotasi. Hasil optimasi disimpan dalam format .pdb melalui menu (File > 

Save As > Ligan [Zn(phe)₂], [Zn(tyr)₂], dan pioglitazon > OK). 
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3.3.5. Validasi Metode Docking 

 

 
Validasi metode molecular docking dilakukan melalui proses redocking antara ligan 

bawaan dan reseptor target (4L7F) yang diunduh dari Protein Data Bank (PDB) 

menggunakan perangkat lunak AutoDock Tools yang dapat dilihat pada lampiran 1 

gambar 21. Evaluasi validasi didasarkan pada nilai RMSD, kesesuaian situs 

pengikatan, serta parameter yang digunakan. Metode dianggap valid apabila nilai 

Root Mean Square Deviation (RMSD) ≤ 2 Å. Tahapan pada proses ini dilakukan 

sebagai berikut: 

 

A. Preparasi Reseptor dan Ligan 

AutoDock Tools 1.5.7 dijalankan terlebih dahulu menyalin alamat folder tempat 

penyimpanan reseptor dan ligan. Software dibuka melalui menu (File > References > 

Paste Alamat Folder > Set) untuk menetapkan direktori kerja. Setelah pengaturan 

selesai, tahap preparasi reseptor dan ligan dapat dilakukan. 

Preparasi reseptor dimulai dengan membuka file Reseptor.pdb melalui (File > Read 

Molecule > pilih Reseptor.pdb). Reseptor yang telah dimuat ke dalam AutoDock 

Tools diberi muatan melalui (Edit > Charges > Add Charges > OK) dan 

ditambahkan hidrogen polar menggunakan (Edit > Hydrogens > Add > Polar Only > 

OK). Reseptor yang telah dipreparasi disimpan dalam format .pdbqt melalui (Grid > 

Macromolecule > Choose > Reseptor > Select Molecule > OK). Layar kerja 

dibersihkan menggunakan (Edit > Delete > Delete All Molecule > Continue) 

sebelum melanjutkan ke tahap berikutnya. 

Preparasi ligan dilakukan dengan prosedur serupa. File Ligan.pdb dibuka melalui 

(File > Read Molecule > pilih Ligan.pdb), kemudian dilakukan penambahan muatan 

(Edit > Charges > Add Charges > OK) dan penambahan hidrogen melalui (Edit > 

Hydrogens > Add > All Hydrogens > OK). Hidrogen non-polar digabung 

menggunakan (Edit > Hydrogens > Merge Non Polar), sedangkan hidrogen yang 



  24 

tidak diperlukan dihapus melalui (Edit > Hydrogens > Delete > Delete Hydrogens > 

OK). Ligan dipilih melalui (Ligand > Input > Choose > Ligand Select molecule for 

AutoDock4 > OK), kemudian dilakukan deteksi root (Ligand > Torsion Tree > 

Detect Root), pemilihan root (Ligand > Torsion Tree > Choose Root), dan penentuan 

jumlah torsion (Ligand > Torsion Tree > Choose Torsions > DONE; Ligand > 

Torsion Tree > Set Number of Torsions). Hasil preparasi disimpan dalam format 

.pdbqt melalui (Ligand > Output > Save As PDBQT > OK). 

 
B. Mengatur Grid  

 

Pengaturan grid box dilakukan menggunakan perangkat lunak AutoDock Tools 1.5.7. 

Koordinat grid box ditentukan berdasarkan posisi ligan yang terdapat pada file 

reseptor hasil validasi seperti pada lampiran 1 gambar 25. Penetapan grid box 

menjadi acuan untuk proses docking senyawa uji terhadap reseptor yang telah 

divalidasi sebelumnya. Rincian pengaturan grid center dan dimensi grid box pada 

penelitian ini disajikan pada Tabel 1. 

 

Tabel 1. Pengaturan grid center dan dimensi gridbox 

 

Grid box 

Center Dimensi (A) 

Protein X Y Z X Y Z 

4L7F -4,963 54,083 4,844 20 20 20 

 

B.1. Menentukan lokasi docking pada reseptor 
 

File reseptor dibuka dengan memilih menu (Grid > Macromolecule > Open > 

Reseptor.pdbqt) kemudian klik “YES”. Selanjutnya, tipe peta diatur melalui pilihan 

(Grid > Set Map Types > Open Ligand > Ligan.pdbqt). Molekul reseptor dipilih 

kembali melalui (Grid > Macromolecule > Choose > Reseptor > Select Molecule) 

dan dikonfirmasi dengan klik “YES”. Setelah itu, ligan ditentukan dengan memilih 

(Grid > Set Map Types > Choose Ligand > Ligand > Select Ligand). 
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B.2. Menentukan ukuran grid box 

 
Grid box dipusatkan pada ligan melalui menu (Grid > Grid Box > Center > Center 

on Ligand), sedangkan ukuran pada sumbu x, y, dan z disesuaikan sesuai kebutuhan 

area aktif reseptor. Pengaturan disimpan menggunakan menu (File > Close saving 

current) untuk mempertahankan konfigurasi yang telah dibuat. Hasil konfigurasi grid 

box disimpan dalam format .gpf melalui (Grid > Output > Save GPF). Informasi nilai 

koordinat dan dimensi grid box kemudian dicatat ke dalam berkas konfigurasi 

(config) menggunakan aplikasi Notepad. 

 

B.3. Membuat File Config 
 

File Config harus berisi mengenai informasi yang akan digunakan untuk proses 

docking pada Autodock Vina. Adapaun informasi dari file config yaitu: 

 

receptor = 4L7F_pure.pdbqt 

ligand = Nativeligand.pdbqt 

 

center_x = -4,963 

center_y = 54,083 

center_z = 4,844 

 

size_x = 20 

size_y = 20 

size_z = 20 

 

log = Nativeligand.txt 

num_modes = 20 

exhaustiveness = 16 
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C. Running Docking 

Pengaturan docking yang telah selesai kemudian menjalankan senyawa uji 

menggunakan AutoDock Vina. Proses docking tersebut menggunakan beberapa 

parameter, yaitu ukuran grid box (x = 20, y = 20, z = 20), titik pusat grid box (x = -

4,963, y = 54,083, z = 4,844), jarak antar grid (spacing) sebesar 1.000 Å, jumlah run 

sebanyak 20, dan nilai exhaustiveness sebesar 6. Proses tersebut menghasilkan output 

dalam format .txt dan .pdbqt yang dapat dibuka menggunakan Notepad dan dapat 

dilihat pada lampiran 1 gambar 26. 

Docking menggunakan AutoDock Vina dilakukan pada software Command Prompt. 

Ketik perintah “vina.exe” pada Command Prompt untuk menampilkan informasi 

proses docking. Salin direktori kerja yang berisi file reseptor.pdbqt, 

Nativeligand.pdbqt, dan file config. Ketik perintah “cd” lalu tempelkan direktori kerja 

tersebut pada Command Prompt. Jalankan perintah “vina.exe --config config.txt” 

dengan menekan enter. Proses docking berlangsung hingga mencapai 100% pada 

Command Prompt seperti pada lampiran 1 gambar 23. 

Proses docking tersebut menampilkan hasil berupa nilai RMSD dan binding energy 

pada Command Prompt. Sistem juga menghasilkan file .txt pada direktori kerja. 

Pengguna kemudian memisahkan hasil docking dengan mengetik perintah 

“vina_split.exe --input Nativeligand.pdbqt” dan menekan enter. Proses tersebut 

menghasilkan 20 file docking yang telah terpisah dalam direktori kerja. Pemisahan 

file tersebut bertujuan untuk menghitung nilai RMSD nativeligand sehingga dapat 

menentukan nilai RMSD terbaik menggunakan software PyMOL seperti pada 

lampiran 1 gambar 22. 

 

 

3.3.6. Analisis Hasil Docking dan Visualisasi 3D 

 

Proses analisis hasil docking dilakukan dengan membuka file keluaran berekstensi 

.txt dan .pdbqt pada direktori kerja. File keluaran tersebut memuat informasi penting 
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terkait proses docking berupa data energi ikatan (binding energy) dari setiap 

konformasi ligan serta nilai RMSD (Root Mean Square Deviation) yang 

menunjukkan tingkat penyimpangan struktur antar konformasi. 

Data tersebut kemudian digunakan untuk menentukan konformasi yang paling stabil 

dan representatif. Penentuan konformasi tersebut didasarkan pada nilai energi ikatan 

terendah serta konsistensi posisi ligan terhadap sisi aktif protein. Nilai RMSD pada 

hasil docking dihitung menggunakan software PyMOL. 

Konformasi terpilih selanjutnya disimpan dalam format .pdb untuk keperluan analisis 

lanjutan menggunakan software Discovery Studio Visualizer 2025. Analisis lanjutan 

kemudian dilakukan melalui menu Ligand Interaction > Show 2D Diagram pada 

software tersebut. Menu tersebut menampilkan representasi visual interaksi antara 

ligan dan protein target yang dapat dilihat pada lampiran 1 gambar 28. 

Tahap analisis ini mengidentifikasi jenis interaksi yang terjadi, terutama ikatan 

hidrogen, serta menentukan residu asam amino pada sisi aktif protein yang berperan 

dalam pengikatan ligan. Analisis tersebut memberikan gambaran kestabilan interaksi 

serta menunjukkan detail molekuler yang relevan untuk memahami mekanisme 

ikatan antara ligan dan protein target. 

 
 

3.3.7. Diagram Alir Penelitian 

 

 

Berdasarkan seluruh proses prosedur di atas, maka dapat dirangkum ke dalam bentuk 

diagram alir sebagai pada gambar berikut: 
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1. Preparasi Struktur Senyawa Kompleks 

 

 

- dibuat struktur 2D pada software Avogadro. 

- di Edit > Copy as SMILES (digunakan selanjutnya 

untuk parameter farmakokinetik). 

- disimpan dalam format (.pdb) 

 

 

Gambar 5. Diagram Alir Penelitian Preparasi Struktur Senyawa Kompleks 

 

2. Analisis Farmakokinetik senyawa 

 

 

-dianalisis dengan program Lipinski’s Rule of Five untuk 

memperoleh informasi kelayakan senyawa 

-dianalisis dengan program Pre-ADME untuk 

memperoleh prediksi ADME 

-dianalisis dengan program protox untuk memperoleh 

prediksi toksisitas senyawa  

-diinterpretasikan hasil untuk kesimpulan potensi ligan 

sebagai kandidat obat 

  

Gambar 6. Diagram Alir Penelitian Analisis Farmakokinetik 
 

 

 

 

 

 

 

 

Struktur [Zn(Phe)2], [Zn(Tyr)2], Pioglitazon 

Ligan dengan format .pdb/.pdbqt 

Ligan ([Zn(Phe)2], [Zn(Tyr)2], Pioglitazon) 

dengan format .pdb 

Hasil Farmakokinetik 
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3. Pemilihan Protein Target 

 
 

              - diidentifikasi menggunakan situs    

    https://swisstargetprediction.ch/. 

             - dianalisis interaksi protein menggunakan STRING DB 

                dipilih berdasarkan keterlibatan dalam resistensi insulin 

 

Gambar 7. Diagram Alir Pemilihan Protein Target 

 

 

4. Preparasi Reseptor 4L7F 

 
 

- diunduh protein dari situs https://www.rcsb.org/ 

- dilakukan pembersihan dengan menghilangkan residu 

air serta native ligand menggunakan Discovery Studio 

Visualizer. 

 

Gambar 8. Diagram Alir Penelitian Preparasi Reseptor 4L7F 

 

5. Preparasi Ligan 4L7F 
 

 

 

- diunduh protein dari situs https://www.rcsb.org/ 

-  dilakukan pembersihan dengan menghilangkan residu 

air dan protein menggunakan Discovery Studio 

Visualizer. 

  

 

Gambar 9. Diagram Alir Penelitian Preparasi Ligan 4L7F 
 
 
 

 
 

Protein 4L7F 

Reseptor 4L7F.pdb 

Protein 4L7F 

Ligan 4L7F.pdb 

Protein MAPK8 (4L7F) 

Protein 4L7F 

https://swisstargetprediction.ch/
https://www.rcsb.org/
https://www.rcsb.org/
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6. Docking dan Visualisasi 3D 

 

  

- dilakukan docking dengan Reseptor 4L7F.pdb pada 

software Autodock Vina 

 
 

- didapatkan nilai RMSD dan energi bebas Gibs 

 

- dianalis pada konformasi terbaik dengan software 

Pymol 

 

- divisualisasi dengan software Discovery Studio 

Visualization 

- dianalisa residu asam amino pada sisi aktif protein 

 

Gambar 10. Diagram Alir Penelitian Docking dan Visualisasi 3D

Ligan.pdbqt 

Hasil Docking 

Format file .dlg 

Senyawa Kompleks .pdbqt 

Hasil 



 

V. SIMPULAN DAN SARAN 

 

 

 

5.1.  Simpulan 
 
 

Adapun kesimpulan yang didapat dari penelitian ini adalah: 

 

1. Senyawa kompleks Zn(II)-fenilalanin dan Zn(II)-tirosin menunjukkan sifat 

farmakokinetik yang baik berdasarkan hasil analisis Lipinski’s Rule of Five, Pre-

ADME, dan Protox. Senyawa Zn(II)-fenilalanin memiliki berat molekul 342 Da, 

HIA sebesar 98,75%, Caco-2 sebesar 5,96 nm/s, dan PPB 100%, sedangkan 

Zn(II)-tirosin memiliki berat molekul 374 Da, HIA sebesar 90,38%, Caco-2 

sebesar 6,35 nm/s, dan PPB 100%. Kedua senyawa juga menunjukkan hasil 

Protox kategori inactive pada seluruh parameter toksisitas. Pioglitazon memiliki 

HIA sebesar 94% dan Caco-2 sebesar 25,98 nm/s, namun menunjukkan potensi 

hepatotoksisitas dengan status active (0,51).  

 
2. Senyawa kompleks Zn(II)-fenilalanin, Zn(II)-tirosin, dan pioglitazon 

menunjukkan interaksi dengan protein target 4L7F (MAPK8) berdasarkan hasil 

molecular docking. Interaksi tersebut melibatkan residu penting seperti Lys55, 

Arg69, Glu73, Glu109, Met111, Gln117, Asn156, dan Asp169 pada sisi aktif 

protein. Hasil validasi redocking menunjukkan nilai RMSD sebesar 0.337 Å, 

sehingga metode docking dinyatakan valid dan akurat.  

 
3. Senyawa kompleks Zn(II)-tirosin menunjukkan nilai energi ikatan paling rendah 

sebesar -13,00 kkal/mol dengan RMSD 0,337 Å, sedangkan Zn(II)-fenilalanin 

menunjukkan nilai energi ikatan sebesar -10,00 kkal/mol dengan RMSD 1,459 
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Å. Nilai energi negatif menunjukkan bahwa interaksi ligan dengan protein 

bersifat stabil. Interaksi tersebut didukung oleh ikatan hidrogen, van der Waals, 

dan interaksi π-anion pada residu sisi aktif protein. Senyawa Zn(II)-tirosin 

menunjukkan potensi terbaik sebagai kandidat antidiabetes karena memiliki 

afinitas pengikatan yang lebih kuat dan profil keamanan yang baik. 

 

 

5.2.  Saran 
 

Penelitian selanjutnya perlu melakukan uji lanjutan secara in vivo untuk memastikan 

aktivitas antidiabetes secara langsung, serta perlu dilakukan analisis in silico 

menggunakan software lain untuk membandingkan dan memvalidasi hasil molecular 

docking sehingga diperoleh hasil yang lebih akurat dan reliabel. 
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