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BAB II 

TINJAUAN PUSTAKA 

 

 

2.1 Komputerisasi 

Komputerisasi merupakan suatu peralatan elektronik yang dilengkapi dengan 

mikroprosesor yang terdiri dari ribuan rangkaian elektronik . Dalam sistem 

komputer , prosesor merupakan otak yang mampu mengolah data dengan bantuan 

program agar dapat menghasilkan informasi yang diinginkan. Kata komputer  

berasal dari Bahasa Inggris yaito computer, yang berasal dari kata kerja “ to 

compute” yang artinya mengitung. 

 

2.2 Sistem 

Menurut Davis (1991), sistem dapat abstrak atau fasis. Sistem yang abstrak adalah 

susunan yang teratur dari gagasan-gagasan yang saling bergantung , misalnya 

sistem teknologi adalah sususan yang teratur  dari gagasan-gagasan tentang 

Tuhan, manusia dan sebagainya. Dan sistem yang bersifat fasis adalah 

serangkaian unsur yang bekerja sama untuk mencapai tujuan tertentu. 

 

Menurut Gie (1967), sistem adalah suatu kebulatan dari bagian-bagian atau 

unsure-unsur yang saling  berhubungan menurut satu pengaturan yang tertib guna 

mencapai maksud tertentu. 
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Pengertian sistem adalah suatu susunan yang teratur dari kegiatan-kegiatan yang 

saling bergantung dari prosedur-prosedur yang saling berhubungan yang 

melaksanakan dan mempermudah kegiatan-kegiatan utama organisasi. Suatu 

sistem terdiri dari komponen-komponen  yang saling berkaitan dan bekerja sama 

untuk mencapai suatu tujuan . Sistem merupakan jarinagan dari elemen-elemen 

yang saling berhubungan membentuk suatu kesatuan untuk melaksanakan suatu 

tujuan. Tujuan dari sistem ini mengolah data untuk menghasilkan informasi. Agar 

terlaksana dengan baik tujuan ini harus ada elemen-elemen yang mendukung. 

Elemen pendukung ini akan selalu berhubungan dan membentuk suatu kesatuan, 

diantaranya yaitu : 

 

2.2.1. Perangkat Keras ( hardware ) 

Perangkat keras adalah peralatan fisik dari suatu sistem yang terdiri dari perangkat 

masukan, perangkat pengolahan. Contoh perangkat masukan ( Input device ): 

Keyboard, Scanner, Mouse, CDROM, Microphone, Camera, dll. Contoh 

perangkat pengolahan ( Processing Device ): Processor, RAM, IC. Contoh 

perangkat keluaran ( Output Device ): Monitor, Printer, Speaker, dll. 

 

2.2.2. Perangkat Lunak ( Software ) 

Perangkat lunak adalah serangkaian perintah atau instruksi yang di tulis dengan 

bahasa pemrograman untuk menghasilkan tujuan tertentu. 

 

 

 



6 
 

2.3. Karakteristik Sistem 

Suatu sistem mempunyai karakteristik/sifat tertentu , antara lain : 

a. Komponen  Sistem ( Component ) 

Sistem terdiri dari sejumlah komponen yang saling berhubungan dan 

berinteraksi satu dengan   yang lainnya membentuk satu kesatuan yang 

utuh untuk mencapai satu tujuan. 

b. Batasan Sistem ( Boundary ) 

Batasan sistem merupakan   pembatasan suatu sistem dengan sistem 

lainnya. 

c. Lingkungan Luar Sistem (Environment ) 

Lingkungan luar sistem merupakan lingkungan luar dari sistem yang 

saling mempengaruhi jalannya sistem. 

d. Penghubung Sistem ( Interface ) 

Penghubung sistem merupakan penghubung sistem yang digunakan 

sebagai alat interaksi antara sub sistem dengan sub sistem yang lainnya. 

e. Masukan Sistem ( Input ) 

Masukan sistem berupa signal yang di lakukan untuk segala kegiatan yang 

memberikan energi baik secara manual maupun terprogram. 

f. Keluaran Sistem (Output ) 

Keluaran sistem merupakan keluaran sistem dari hasil masukan menjadi 

keluaran yang diolah sebagai keluaran yang berguna. 
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g. Pengolahan Sistem (Procces)  

Pengolahan sistem merupakan sistem yang merubah masukan menjadi 

keluaran yang dilakukan oleh pengolah sistem itu sendiri. 

h. Sasaran sistem ( Objek ) 

Sasaran yang tepat untuk mencapai suatu sasaran dari tujuan yang 

ditentukan  maka dari itu jika suatu sistem tidak memiliki sasaran maka 

operasi sistem tersebut tidak ada gunanya. 

 

2.4.  Data 

Merupakan bentuk jamak dari datum yang berarti catatan, kenyataan. Data adalah 

fakta-fakta yang berhubungan dengan kejadian-kejadian yang dapat di kenal dan 

dapat di kenal dan dapat dia atur. Pada dasarnya data adalah bahan mentah yang 

masih harus di tangani dan di tempuh dalam suatu proses data, sebelum data 

tersebut dapat  berguna bagi penerima. Data dapat meliputi kata-kata, grafik, 

bagan maupun symbol yang menggambarkan suatu ide, objek, kondisi atau situasi 

tertentu .  

 

2.5. Sistem Informasi 

Menurut Gie ( 1967 ), sistem informasi adalah suatu sistem di dalam organisasi 

yang mempertemukan kebutuhan transaksi harian, mendukung operasi yang 

bersifat manajerial dan kegiatan strategis dari suatu organisasi dan menyediakan 

pihak luar tertentu dengan laporan-laporan yang diperlukan. 
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2.6.Perangkat Keras 

Perangkat keras ( Hardware ) computer mencakup peralatan fisik yang 

keseluruhan yang sering disebut komputer itu sendiri. Peralatan ini mencakup unit 

processor pusat ( CPU ), peralatan masukan (Input), peralatan keluaran (Output). 

Komponen-komponen dasar dari komputer ini pada dasarnya terlepas dari ukuran 

komputer tersebut yang akan mempengaruhi keseluruhan kemampuan 

pemrosesan. 

 

2.6.1. Central Prosesor Unit (CPU)  

CPU adalah bagian intern dari computer yang menjalankan instruksi-

instruksi yang diberikan oleh program-program komputer. Unit ini 

merupakan “otak” dari kompuetr dan tempat mengatur jalannya suatu 

sistem operasi pada sebuah komputer serta mengendalikan sistem operasi 

komputer. CPU berfungsi untuk : 

1. Memberikan alamat (address) pada data \dan instruksi di dalam 

internal storage. 

2. Mengambil dan memasukkan data. 

3. Melaksanakan pengolahan data berdasarkan kalkulasi dan 

perbandingan. 

4. Melaksanakan instruksi. 
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2.6.2. Peralatan masukan ( Input Device ) 

Adapun peralatan masukan yang paling umum dan banyak di gunakan 

adalah keyboard. Alat ini merupakan bagian dari komputer yang berfungsi 

sebagai media untuk memasukkan data-data yang diinginkan, menulis, 

mengedit program (teks) serta mengirim perintah-perintah ke operating 

system. 

 

2.6.3. Peralatan keluaran (Output Device) 

Peralatan keluaran pada sistem operasi computer ini dapat berbentuk : 

a. Hardcopy Device   

Yang termasuk hardcopy device adalah printer yang digunakan untuk 

mencetak tulisan, kata, angka, karakter, khusus dan simbol-simbol lainnya 

serta image (grafik/gambar) pada media kertas. 

b. Softcopy Device 

Softcopy device merupakan alat yang digunakan untuk menampilkan 

tulisan-tulisan kata, angka, karakter khusus, dan symbol, dan symbol-

simbol lainnya) serta image (grafik/gambar) pada media video display 

(monitor), flat panel display, dan speaker. 

2.7. Perangkat Lunak 

Dalam pembuatan Profile FMIPA Universitas Lampung ini digunakan perangkat 

lunak berupa program aplikasi. Program aplikasi yang digunakan adalah Adobe 

Photoshop CS 4 , Macromedia Flash 8. 
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2.8. Macromedia Flash 8 

Menurut Suciadi (2003) Tahun 1996 sebuah perusahaan kecil yang bernama 

Future Wave membuat program yang di beri nama Future Splash Animator, 

sebuah aplikasi sederhana yang dirancang untuk membuat linier, animasi-animasi 

berbasiss vector. Setelah aplikasi ini mendapat respon yang baik dan digunakan 

untuk mendesain Microsoft’s web version of MSN dan Disney’s subscription-

based Disney Daily Blast. Pada November 1996, Macromedia menawarkan untuk 

bekerjasama dengan Future Wave yang hanya mempunyai 6 pekerja. Pada 

Desember 1996, Future Wave menjual teknologinya ke Macromedia, yang 

mengeluarkan Flash 1 pada awal tahun 1997. 

 

2.8.1. Sekilas Tentang Macromedia Flash 8 

 a. Timeline 

 Timeline digunakan untuk mengatur dan mengontrol isi keseluruhan Movie. 

  

Gambar 2.1 Timeline Window 
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b. Tool Box 

      Tool Box berisi alat-alat yang digunakan untuk menggambarkan objek pada stage. 

 

 

 

 

 

 Gambar 2.2 Tools Window 

 

 

c. Stage 

Stage merupakan tempat dimana untuk membuat sebuah animasi 

 

 

 

 

 

 

 

Gambar 2.3 Stage Window 

 

 

 

 



12 
 

d. Properties 

Properties merupakan window yang digunakan untuk mengatur property dari 

objek. 

   

Gambar 2.4 Propertis Window 

 

e. Actions 

Actions merupakan window yang digunakan untuk menuliskan Action Script. 

Untuk Flash Action Script digunakan untuk mengendalikan objek, maupun 

coding. 

 

Gambar 2.5 Actions Window 
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f. Color 

Color  digunakan untuk memberi warna pada objek yang di buat sesuai dengan  

warna pada window. Color ini terdiri dari dua tab yaitu Color Mixer dan Color 

Swatches. 

 

 

 

 

 

 

 

Gambar 2.6 Color Mixer Window 

 

 

 

 

 

 

 

 

 

Gambar 2.7 Color Swatch Window 
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g. Components 

Menu component telah tersedia dan tinggal menggunakannya. 

 

 

 

 

 

Gambar 2.8 Component Window 

 

h. Bekerja dengan Teks 

Flash mempunyai tiga jenis teks, yaitu tipe statis (Static Text), dinamis 

(Dynamic Text), dan input (Input Text). Text statis merupakan teks yang 

bersifat tetap. Teks ini akan digunakan untuk menulis teks biasa. Teks tipe 

statis di tujukan untuk membuat animasi teks. Teks dinamis merupakan 

teks yang bersifat dinamis, bisa berubah sesuai dengan aturan perubahan 

yang di buat pada program atau script. Teks dinamis biasanya digunakan 

pada program untuk menampilkan jam atau tanggal pada saat ini. Teks 

input merupakan teks yang bisa digunakan sebagai masukan pada 

program. Teks tipe input misalnya digunakan pada program untuk 

memasukkan nama atau email pada sebuah guest book. Penulisan teks 

pada flash bisa di atur menggunakan parameter-parameter yang dapat di 

peroleh pada PROPERTIES 
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i. Menulis Teks 

Menulis teks pada flash sama mudahnya dengan menulis teks pada aplikasi 

pengolah kata yang lain. Perbedaannya, pada flash orientasinya adalah teks 

di buat dalam rangka untuk membuat sebuah program animasi. 

Untuk menulis teks pada stage, bisa menggunakan tool Text pada 

Toolbox, dan langkah yang diperlu dilakukan : 

1. Klik tool Text pada Toolbox. 

2. Arahkan mouse pada stage, kursor akan berubah bentuk 

menjadi tanda (+) dengan Huruf ‘A’ di samping kanan 

bawahnya. 

3. Klik dan drag mouse untuk membuat kotak yang akan di 

jadikan tempat menulis teks. Setelah itu, lepaskan mouse. 

4. Tulis teks yang di masukkan. Tekan Enter jika ingin 

membuat sebuat baris yang baru. 

5. Untuk mengakhiri penulisan, klik mouse di sembarang 

tempat pada stage atau tekan tombol Esc. 

j. Membuat Symbol 

Membuat symbol dapat di lakukan sebelum atau sesudah membuat objek 

yang akan di jadikan symbol. Cara membuat symbol sebelum membuat 

objek : 

1. Buka kotak dialog Create New Symbol dengan : 

1. Klik menu Insert > New symbol. 

2. Tekan Ctrl + F8. 
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3. Pada panel Library pilih ikon Create New Symbol, 

yang terletak pada pojok kiri bawah. 

2. Pada kolom Name, isi nama symbol yang akan di buat.   

Usahakan nama di sesuaikan dengan bentuk atau sifat objek 

yang di buat. 

Behavior  merupakan sifat objek symbol yang di buat. 

3. Tentukan behavior symbol. Ada tiga pilihan behavior: 

1. Movie clip, symbol yang berupa animasi atau klip    

 film. 

2. Button, symbol yang berupa tombol interaktif yang 

 dapat di klik. 

3. Graphic. Simbol berupa gambar atau objek statis.   

4.    Tekan OK dan buat objek symbol. 

 

k. Animasi Frame 

Membuat Line Animaton. 

Untuk lebih jelasnya, ikuti langkah-langkah berikut : 

1. Buka area kerja (stage) kosong melalui menu File > New  atau cukup 

klik  ikon New. 

2. Klik pada frame pertama. Buat objek lingkaran kecil menggunakan tool 

 Oval pada Toolbox. 

3. Atur warna lingkaran tersebut menggunakan Fill Color di bagian 

Toolbox, pilih warna sesuai keinginan. 
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4. Di mana frame pertama, salin objek lingkaran yang telah di buat.  

 Letakkan objek hasil salinan tersebut di samping lingkaran pertama 

 dengan  warna berbeda. 

5. Ulang langkah ke-4 sampai membentuk garis dari kumpulan lingkaran 

kecil yang berderet dengan warna yang berbeda-beda. 

6. Klik kanan pada frame ke-2, pilih menu Insert Keyframe. Edit warna tiap 

lingkaran tersebut dengan warna yang berbeda-beda. 

7. Ulang langkah ke-6 untuk frame ke-3, ke-4 dan ke-5. 

8. Jalankan animasi melalui menu Control > Test Movie atau  tekan 

Ctrl +  Enter. 

9. Simpan animasi melalui menu File > Save As atau Ctrl + S.  Beri 

nama   dengan garis. 

Setelah membuat animasi garis dengan menata lingkaran-lingkaran kecil yang 

berwarna-warni. 

Jika di perhatikan, animasi 1 yang telah di buat berjalan dengan cepat. 

Perubahan antar keyframe terjadi dengan cepat, yaitu per 1 frame dapat 

membuat animasi berjalan dengan lebih lambat dengan cara menyisipkan 

frame diantara keyframe. Cara menambah frame diantara keyframe adalah 

sebagai berikut : 

1. Buka file garis.fla yang telah di buat. 

2. Klik keyframe pertama, tambahkan keyframe dengan cara : 

1. Klik menu Insert > Timeline > Frame 

2. Klik kanan mouse pada keyframe, pilih Insert  Frame. 

3. Tekan tombol F5 
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3. Lakukan penambahan frame dengan melakukan langkah                                          

pertama berulangkali sampai keyframe ke-2 berada pada posisi 

frame ke-5. 

4. Klik keyframe ke-2 pada frame ke-5 lakukan seperti langkah ke-2 

sampai keyframe ke-3 berada pada posisi frame ke-10. 

5. Klik keyframe ke-3 pada frame ke-10. Lakukan seperti pada 

langkah ke-2 sampai keyframe ke-4 berada pada posisi frame ke-

15. 

6. Klik frame ke-4 pada frame ke-15. Lakukan seperti pada langkah 

ke-2 sampai frame ke-5 berada pada posisi frame ke-20. 

7. Klik keyframe ke-5 pada frame ke-20. Lakukan seperti pada 

langkah ke-2 sampai pada posisi frame ke-24. 

8. Jalankan test movie dengan Ctrl + Enter. 

Jika di perhatikan, jalannya animasi ke-2, menjadi lebih lambat 

dari pada animasi pertama. Hal ini terjadi karena animasi pertama 

hanya terdiri dari lima frame, sedangkan animasi ke-2 terdiri dari 

dua puluh empat frame dengan transisi perubahan perlima frame. 

 

l. Bekerja dengan Sound 

Cara mengimpor sound : 

1. Klik menu File > Import to Library. 

2. Muncul kotak dialog Import to Library. Pilih salah satu file 

saound yang diinginkan, kemudian klik Open. 
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3. Flash akan melakukan proses penyimpanan symbol sound 

yang telah di impor ke dalam Library. 

4. Buka panel Library untuk melihat symbol sound yang telah 

di impor. 

Beberapa format sound yang dapat di impor ke dalam flash antara 

lain : 

1. Format WAV (Windows) 

2. Format AIFF (Macintosh) 

3. Format MP3 (Windows atau Macintosh) 

m. Mengenal Efek 

Efek sangat sering di gunakan untuk membuat animasi yang menarik. 

Salah satunya bisa menggunakan bermacam efek yang telah di sediakan 

oleh flash dan menggabungkan dengan animasi lain sehingga 

membentuk satu kesatuan  movie. Dalam Flash, efek dapat di 

kelompokan menjadi dua bagian yaitu : 

- Efek Color, merupakan efek yang memanipulasi warna tampilan 

 objek tanpa manipulasi atau mengubah objek itu sendiri. Efek ini 

 dapat di gunakan pada panel Propertis di bagian Color. Efek Color  

 hanya dapat di gunakan pada objek symbol sehingga apabila ingin 

 menggunakan efek Color harus mengkonversi objek gambar 

 (bukan symbol) menjadi symbol. 

- Efek Timeline merupakan efek yang secara langsung 

 memanipulasi objek. Efek timeline dapat di gunakan hampir untuk 
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 semua macam objek sehingga tidak harus mengkonversi objek 

 gambar menjadi symbol lebih dulu. 

Cara menggunakan efek timeline : 

1. Klik menu Insert > Timeline Effect, kemudian pilih group 

 efek yang di maksud. 

2. Klik kanan pada objek dan pilih Timeline Effect pada pop-

 up menu yang muncul. 


