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STUDI IN SILICO AKTIVITAS TURUNAN GENISTEIN SEBAGAI 

ANTIDIABETES 
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MUHAMMAD IRSAD 

 

 

 

 

Penelitian pengembangan obat secara in silico saat ini telah banyak dilakukan, 

salah satunya adalah pengembangan obat antidiabetes.  Salah satu langkah 

mengobati diabetes adalah dengan menghambat aktivitas enzim DPP-4, suatu 

enzim yang menghambat kinerja hormon inkretin, sehingga penghambatan enzim 

DPP-4 akan menstimulasi sekresi insulin.  Genistein merupakan senyawa yang 

telah terbukti memiliki aktivitas antidiabetes dengan cara menghambat aktivitas 

enzim DPP-4.  Berdasarkan dari struktur senyawanya, genistein memiliki 3 gugus 

hidroksil (-OH).  Penelitian ini bertujuan untuk melihat potensi turunan genistein 

dengan penggantian gugus hidroksil posisi C ke-7 dengan gugus -H, -CH3, -NH2 

dan -OCH3 sebagai kandidat antidiabetes yang lebih baik.  Uji molecular docking 

ligan sampel dilakukan terhadap enzim DPP-4 (PDB ID: 4n8e) menggunakan 

software PLANTS dan divisualisasikan dengan software LigPlus dan PyMOL.  

Keempat ligan sampel berhasil menempati posisi sisi aktif protein dan berinteraksi 

dengan residu asam amino sisi aktif protein.  Ligan F (5-hydroxy-3-(4-

hydroxyphenyl)-7-methoxy-4H-chromen-4-One) yang merupakan turunan 

genistein dengan gugus fungsi metoksi (-OCH3), menunjukkan hasil yang lebih 

baik dibandingkan genistein dengan skor docking sebesar -78.5436 serta mampu 

menempati posisi yang mirip dengan Sitagliptin, sehingga interaksi terhadap 

residu asam amino sisi aktif juga menjadi lebih baik.  Hasil analisis 

farmakokinetik juga menunjukkan bahwa ligan F mampu terabsorpsi dan 

terdistribusi dengan baik serta tidak bersifat toksik, sehingga ligan F berpotensi 

sebagai kandidat antidiabetes yang lebih baik dibandingkan ligan sampel lainnya. 

 

Kata kunci : 5-hydroxy-3-(4-hydroxyphenyl)-7-methoxy-4H-chromen-4-One, 

RMSD, Genistein, Enzim DPP-4, Molecular Docking, 
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Currently, there have been many researches on in silico drug development, one of 

which is the development of antidiabetic drugs.  One of the steps to treat diabetes 

is to inhibit the activity of the DPP-4 enzyme, an enzyme that inhibits the 

performance of incretin hormones, so that inhibition of the DPP-4 enzyme will 

stimulate insulin secretion.  Genistein is a compound that has been shown to have 

antidiabetic activity by inhibiting the activity of the DPP-4 enzyme.  Based on the 

structure of the compound, genistein has 3 hydroxyl groups (-OH).  This study 

aims to see the potential of genistein derivatives by replacing the 7th C hydroxyl 

group with -H, -CH3, -NH2 and -OCH3 groups as better antidiabetic candidates. 

Molecular ligand docking test of samples was carried out on the DPP-4 enzyme 

(PDB ID: 4n8e) using PLANTS software and visualized with LigPlus and 

PyMOL software.  The four sample ligands succeeded in occupying the active site 

of the protein and interacting with amino acid residues of the active protein site. 

Ligand F (5-hydroxy-3-(4-hydroxyphenyl)-7-methoxy-4H-chromen-4-One), 

which is a genistein derivative with a methoxy functional group (-OCH3), showed 

better results than genistein with a docking score of -78.5436 and is able to 

occupy a position similar to Sitagliptin, so that the interaction with the active side 

of the amino acid residue is also better.  The results of the pharmacokinetic 

analysis also showed that the F ligand was able to be absorbed and distributed 

well and was not toxic, so that the F ligand had the potential to be a better 

antidiabetic candidate than the other sample ligands. 

 

Keywords : 5-hydroxy-3-(4-hydroxyphenyl)-7-methoxy-4H-chromen-4-One, 

RMSD, Genistein, DPP-4 Enzyme, Molecular Docking, 
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I. PENDAHULUAN 

 

 

 

 

1.1. Latar Belakang 

 

 

Diabetes melitus merupakan sebuah penyakit metabolik kronis yang cukup 

mengancam jiwa.  Sebagian besar kematian prematur yang terjadi di berbagai 

wilayah secara global, disebabkan oleh penyakit ini.  Berdasarkan data dari 

International diabetes federation (IDF), pada tahun 2021 diperkirakan terdapat 

537 juta orang di dunia dalam rentang usia antara 20-79 tahun menderita diabetes 

dan angka tersebut diperkirakan akan terus meningkat hingga mencapai 643 juta 

pada tahun 2030 dan 783 juta pada tahun 2045.  Kasus penderita diabetes di 

Indonesia menempati urutan ke-5 setelah negara Cina, India, Pakistan dan 

Amerika Serikat, dengan jumlah kasus sebanyak 19,5 juta penderita, dan 

diperkirakan akan terus meningkat menjadi 28,6 juta penderita pada tahun 2045 

(International Diebetes Federation, 2021).  

 

Diabetes melitus merupakan penyakit metabolik yang ditandai dengan 

meningkatnya kadar gula dalam darah sebagai akibat adanya gangguan 

metabolisme yang berhubungan dengan hormon insulin, suatu hormon yang 

disekresikan oleh sel beta pankreas. Hormon ini berperan dalam membantu gula 

untuk masuk ke dalam sel sehingga dapat disebarkan ke seluruh tubuh. Pada 

penderita diabetes melitus, hormon insulin ini tidak dapat bekerja dengan baik 

yang berdasarkan hal itu juga, diabetes melitus dibagi menjadi 2 tipe, yaitu 

diabetes tipe 1, dimana terjadi kerusakan pada sel beta pankreas akibat dari proses 

autoimun yang menyebabkan hormon insulin tidak dapat dihasilkan, dan diabetes 

tipe 2, dimana sel-sel tubuh menjadi resisten terhadap insulin akibat dari pola 

hidup yang tidak sehat, keadaan ini menyebabkan hormon menjadi tidak efektif 
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dan pada akhirnya mendorong produksi insulin yang berlebih, seiring berjalannya 

waktu, semakin lama produksi insulin tidak memadai sehingga menyebabkan 

kegagalan sel beta pankreas dalam memenuhi permintaan (Fatimah, 2015, 

Pulungan dkk., 2019).  

 

Penanganan diabetes melitus tipe 2, dilakukan dengan adanya perubahan gaya 

hidup dan terapi farmakologis dengan cara pemberian obat antihiperglikemia oral. 

Salah satu obat yang sering diberikan kepada penderita adalah obat yang 

mengandung senyawa sitagliptin seperti Januvia, yaitu obat antidiabetes yang 

bekerja dengan cara menghambat enzim DPP-4 (dipeptidyl peptidase-4). sehingga 

meningkatkan sekresi insulin toleransi glukosa dapat teratasi.  Penggunaan obat 

ini tentu menjadi salah satu pilihan terbaik, namun masih terdapat kekurangan 

dimana adanya efek samping yang dapat ditimbulkan seperti peningkatan resiko 

infeksi dan reaksi alergi, karenanya masih banyak masyarakat yang lebih memilih 

untuk memanfaatkan obat herbal yang relatif lebih mudah dan murah serta 

diperkirakan minim timbulnya efek samping (Sinurat dkk., 2021, Diantari, 2022). 

Salah satu senyawa dari bahan alam yang telah diteliti memiliki efek antidiabetes 

adalah genistein.   

 

Genistein merupakan senyawa yang berasal dari kedelai dan kacang-kacangan.  

Berdasarkan penelitian sebelumnya, genistein dapat meningkatkan sekresi insulin 

dengan cara menghambat enzim DPP-4, sehingga senyawa genistein berpotensi 

sebagai kandidat obat antidiabetes (Diantari, 2022) namun tidak sebaik sitagliptin.  

Berdasarkan struktur senyawanya, genistein memiliki gugus hidroksil yang dapat 

digantikan oleh gugus lain, sehingga akan didapatkan turunan senyawanya, 

dengan tujuan untuk meningkatkan aktivitas senyawa genistein.  Penelitian ini 

menggunakan metode komputasi yaitu molecular docking untuk mengidentifikasi 

potensi senyawa turunan genistein sebagai antidiabetes. 

 

 

 

 

 

 



3 

 

1.2. Tujuan Penelitian 

 

 

Tujuan dari penelitian ini adalah sebagai berikut. 

 

1. Mengidentifikasi jenis interaksi yang terjadi dari tiap ligan sampel. 

2. Mengidentifikasi residu asam amino sisi aktif/sisi pengikatan yang 

berinteraksi terhadap ligan sampel.  

3. Memprediksi senyawa turunan genistein yang memiliki potensi terbaik 

sebagai obat antidiabetes. 

4. Memprediksi potensi toksisitas senyawa turunan genistein sebagai 

antidiabetes. 

 

 

1.3. Manfaat Penelitian 

 

 

Manfaat penilitian ini adalah mengidentifikasi potensi turunan senyawa genistein 

sebagai kandidat obat antidiabetes melalui pendekatan komputasi.  
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II. TINJAUAN PUSTAKA 

 

 

 

 

2.1. Diabetes Melitus 

 

 

Diabetes melitus merupakan penyakit metabolik yang ditandai dengan 

meningkatnya kadar gula darah sebagai akibat dari adanya gangguan pada sistem 

metabolisme.  Gangguan tersebut berkaitan dengan hormon insulin, dimana 

hormon ini merupakan faktor penting dalam lancarnya distribusi gula ke seluruh 

tubuh.  Hormon insulin yang mengalami gangguan, tidak dapat membantu gula 

masuk ke dalam sel dengan baik, sehingga kadar gula dalam darah akan 

meningkat.  Hormon insulin adalah hormon yang dihasilkan oleh sel beta 

pankreas, ketika tubuh mendapatkan asupan makanan, pankreas akan membentuk 

hormon insulin sebagai respon metabolisme tubuh, yang kemudian memantu gula 

pada makanan masuk ke dalam sel-sel tubuh. Berkaitan dengan hormon ini, 

diabetes melitus diabegi menjadi 2, yaitu diabetes melitus tipe 1 dan tipe 2  

(Pulungan dkk., 2019). 

 

Diabetes melitus tipe 1 (DMT1) adalah kondisi dimana pankreas tidak dapat 

menghasilkan hormon insulin.  Ini terjadi karena destruksi sel beta pankreas akibat 

proses autoimun, dimana sistem kekebalan tubuh menyerang sel beta pankreas.  

Penyebab pasti dari terjadinya destruksi ini masih belum sepenuhnya dipahami. 

Namun, penjelasan yang mungkin adalah adanya faktor genetik dan faktor 

lingkungan seperti sebuah virus yang menyebabkan reaksi autoimun (Pulungan 

dkk., 2019). 

 

Diabetes melitus tipe 2 (DMT2) adalah kondisi dimana sel-sel tubuh menjadi 

tidak mampu untuk merespon insulin dengan baik, kondisi ini dikenal juga 

sebagai resistensi insulin,  timbulnya keadaan resistensi insulin ini, menyebabkan 
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hormon menjadi tidak efektif dan pada akhirnya mendorong peningkatan produksi 

insulin.  Seiring berjalannya waktu, semakin lama produksi insulin tidak memadai 

sehingga menyebabkan kegagalan sel beta pankreas dalam memenuhi permintaan.  

Penyebab diabetes tipe ini ada hubungannya dengan kelebihan berat badan dan 

kurangnya aktivitas fisik (Fatimah, 2015).  

 

Selain kedua tipe diabetes di atas, terdapat jenis diabetes lain seperti diabetes 

gestasional, yaitu diabetes yang terjadi selama masa kehamilan sampai proses 

persalinan.  Dibandingkan jenis diabetes lainnya, diperkirakan lebih dari 90% 

kasus diabetes di seluruh dunia adalah kasus diabetes melitus tipe 2 (DMT2).  

Angka ini dapat tercapai karena pada DMT2 secara umum menunjukkan gejala 

yang kurang dramatis dan kondisinya bisa sama sekali tidak menunjukkan gejala. 

Namun, ketika terjadi kekurangan insulin yang parah maka gejala seperti sering 

haus dan buang air kecil akan mulai terlihat, jika kadar gula darah sangat tinggi 

(melebihi 1000 mg/dl) maka penderita akan mengalami dehidrasi hebat yang 

menyebabkan kebingungan mental, pusing, kejang, hingga keadaaan yang disebut 

koma hiperglikemik. Dengan demikian, DMT2 adalah penyumbang terbesar pada 

kasus diabetes di dunia, sehingga penangan diabetes tipe ini perlu terus 

ditingkatkan (Nuraini dan Supriatna, 2016).   

 

 

 

2.2. Penanganan Diabetes Melitus Tipe 2 (DMT2) 

 

 

Manajemen dalam penanganan DMT2 biasanya dilakukan dengan adanya 

perubahan atau modifikasi gaya hidup yang lebih sehat dan terapi farmakologis 

(Fakih dan Dewi, 2020).  Terapi farmakologis yang dilakukan berupa pemberian 

obat antihiperglikemia oral dan salah satu obat yang sering diberikan adalah 

sitagliptin (Januva), seperti pada Gambar 1.  Sitagliptin merupakan obat golongan 

penghambat enzim dipeptidyl peptidase-4 (DPP-4).  Pemberian obat ini bertujuan 

untuk mempertahankan kadar Glucagon-like peptide-1 (GLP-1) dan glucose-

dependent insulinotropic polipeptide (GIP) dalam bentuk aktif di sirkulasi darah 

dengan cara mengikat dan membentuk interaksi pada sisi aktif/sisi pengikatan 

enzim dipeptidyl peptidase-4 lalu menghambat kinerjanya, sehingga dapat 

https://en.wikipedia.org/wiki/Glucose-dependent_insulinotropic_peptide
https://en.wikipedia.org/wiki/Glucose-dependent_insulinotropic_peptide
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memperbaiki toleransi glukosa, meningkatkan respon insulin, dan mengurangi 

sekresi glukagon (Parkeni, 2019). Namun, pemberian obat sitagliptin memiliki 

efek samping seperti peningkatan resiko infeksi dan reaksi alergi (Made dan 

Pathni, 2018.).  Disamping itu, masalah biaya obat sitagliptin dan obat kimia 

lainnya cenderung lebih mahal.  Selain penggunaan obat-obatan kimia, 

masyarakat juga banyak memanfaatkan obat-obatan herbal dalam upaya 

menurunkan kadar gula darah dan biaya yang dikeluarkan lebih murah serta efek 

samping yang kecil atau tidak ada.  Berdasarkan penelitian sebelumnya, obat 

herbal yang telah banyak dimanfaatkan dalam mengurangi kadar glukosa darah 

salah satunya adalah kedelai (Sinurat dkk., 2021, Diantari, 2022). 

 
 

 

Gambar 1. Obat Sitagliptin (Januvia) dan struktur kimianya 

 

 

 

2.3. Enzim Dipeptidyl Peptidase-4 (DPP-4) 

 

 

Dipeptidyl peptidase-4 (DPP-4) merupakan suatu protease serin multifungsi 

dengan fungsi ganda sebagai protease pengatur dan protein pengikat, yang 

terdistribusi secara luas didalam tubuh (Penaforte-Saboia et al., 2021).  Enzim ini 

memecah dua asam amino dari suatu peptida yang mengandung alanin atau prolin 

di posisi peptida N-termilnal.  Enzim DPP-4 memberikan efek anti-apoptosis, 
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regeneratif, dan proliferatif untuk mendorong ekspansi massa sel. Selain itu, 

enzim DPP-4 memiliki peran penting dalam sistem metabolisme tubuh, yaitu 

menurunkan aktivitas hormon inkretin.  Hormon inkretin adalah sebuah hormon 

yang bekerja untuk meningkatkan sekresi insulin dan menurunkan sekresi 

glukagon.  Hormon ini teridiri dari glucagon-like peptide-1 (GLP-1) dan glucose-

dependent insulinotropic polipeptide (GIP) (Perkeni, 2019).  Enzim DPP4 

memiliki sisi aktif yang terdiri dari beberapa residu asam amino, yaitu Glu205, 

Glu206, Asn710, Tyr662, Arg125, Ser630, Phe357, Tyr666, Tyr547, dan Ser209.  

Sisi aktif ini berperan penting sebagai tempat pengikatan (pocket) suatu senyawa 

inhibitor (Sinurat dkk., 2021, Namoto et al., 2014).  Gambar 2, dibawah ini 

merupakan struktur 3D enzim DPP-4 yang diambil dari Protein Data Bank (PDB) 

dengan ID:4n8e.  

 

 

 

2.4. Genistein  

 

 

Genistein merupakan senyawa kimia dengan beberapa gugus hidroksil yang 

terikat pada cincin aromatik, seperti yang terlihat pada Gambar 3.  Kerangka 

strukturnya mirip dengan struktur flavonoid. Namun, bila diperhatikan pada 

senyawa genistein cincin aromatik B (cincin paling kanan) terikat langsung 

melalui atom karbon nomor 3 dari cincin C (cincin di tengah).  Berdasarkan hal 

tersebut senyawa genistein bukan termasuk senyawa flavonoid melainkan 

senyawa isoflavonoid.  

 

 
Gambar 2. Enzim dipeptidyl peptidase-4 (DPP-4) 

https://en.wikipedia.org/wiki/Glucose-dependent_insulinotropic_peptide
https://en.wikipedia.org/wiki/Glucose-dependent_insulinotropic_peptide
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chromen-4-one.  Senyawa ini terdiri dari 15 atom karbon 10 aton hidrogen dan 5 

atom oksigen yang dapat dituliskan formula kimianyanya menjadi C15H10O5. 

Dengan berat molekul 270,24 g/mol, genistein memiliki 3 gugus fenol, 1 gugus 

karbonil dan 1 gugus eter yang terikat pada cincin-cincin karbon (National Center 

for Biotechnology Information, 2022). 

 

Genistein banyak ditemukan dalam kedelai dan produk kacang-kacangan. 

Genistein telah terbukti menunjukkan efek yang menguntungkan pada keadaan 

hiperglikemik karena potensinya merangsang sekresi insulin dengan cara 

menghambat enzim DPP-4 (Rehman dkk., 2019, Diantari, 2022).  Berdasarkan 

struktunya, genistein memiliki gugus hidroksil yang dapat digantikan oleh gugus 

lain, misalnya gugus amina sehingga membentuk senyawa lain yang merupakan 

turunan dari senyawa genistein.  Perubahan satu gugus fungsi suatu senyawa tentu 

mempengaruhi aktivitas senyawa tersebut sehingga turunan senyawa genistein ini 

diperkirakan akan memiliki interaksi yang berbeda dari senyawa genistein 

terhadap enzim DPP-4.  Pada penelitian ini, dari ketiga gugus hidroksil yang ada 

pada struktur genistein, yaitu gugus hidroksil posisi C ke-5, C-ke-7 dan C ke-4, 

dipilih gugus hidroksil posisi C ke-7 yang akan digantikan oleh gugus lain. 

Dengan demikian, dibuatlah struktur senyawa turunan genistein dengan variasi 

beberapa gugus, yaitu  gugus hidrogen (–H), metil (-CH3), amina (-NH2) dan 

metoksi (–OCH3) yang dapat dilihat paga Tabel 1 sebagai berikut. 

 

 

 

 

 

Gambar 3. Genistein 

 

 

Genistein memiliki nama IUPAC, yaitu 5,7-dihydroxy-3-(4-hydroxyphenyl) 

https://pubchem.ncbi.nlm.nih.gov/#query=C15H10O5
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Tabel 1. Senyawa turunan genistein 

 
Struktur Senyawa Nama Senyawa 

 

5-hydroxy-3-(4-

hydroxyphenyl)-4H-

chromen-4-one 

 

5-hydroxy-3-(4-

hydroxyphenyl)-7-methyl-

4H-chromen-4-one 

 

7-amino-5-hydroxy-3-(4-

hydroxyphenyl)-4H-

chromen-4-one 

 

5-hydroxy-3-(4-

hydroxyphenyl)-7-methoxy-

4H-chromen-4-one 

 

 

 

2.5. Aturan Lipinski 

 

 

Senyawa yang berpotensi sebagai kandidat obat sebelumnya haruslah memenuhi 

aturan Lipinski. Pengukuran kelayakan melalui aturan Lipinski dapat menentukan 

sifat fisikokimia senyawa dalam menentukan karakter hidrofobik/hidrofilik untuk 

dapat melalui membran sel oleh difusi pasif (Weni dkk., 2020).  Aturan Lipinski 

terdiri atas lima aturan (Rule of five) yang harus dipenuhi oleh senyawa yang 

dapat dijadikan obat oral, yaitu massa molekul kurang dari ≤ 500 Da, akseptor  

ikatan  hidrogen ≤ 10, donor ikatan hidrogen ≤ 5, log P ≤ 5, dan nilai refraktivtas 

molar berkisar 40-130 (Lipinski, 2004).  
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Suatu obat untuk dapat bekerja baik di dalam tubuh, harus dapat melewati 

membran lipid bilayer, yang mana hal tersebut dipengaruhi oleh massa molekul, 

dimana senyawa dengan massa diatas 500 Da tidak dapat  berdifusi menembus 

membran sel.  Jumlah donor dan akseptor ikatan hidrogen, dimana hal ini 

menggambarkan semakin tingginya kapasitas ikatan hidrogen maka semakin 

tinggi energi yang dibutuhkan agar proses absorpsi dapat terjadi.  Nilai Log P, 

dimana hal ini menggambarkan sifat hidrofobik atau hidrofilik suatu senyawa, 

semakin besar nilai Log P maka semakin hidrofobik senyawa tersebut dan 

senyawa dengan sifat yang terlalu hidrofobik cenderung memiliki tingkat 

toksisitas yang tinggi sebab senyawa tersebut akan tertahan lebih lama pada 

membran lipid bilayer dan juga terdistribusi lebih luas di dalam tubuh sehingga 

selektifitas terhadap enzim target menjadi berkurang.  Semakin rendah nilai Log P 

maka semakin bersifat hidrofilik senyawa tersebut, hal ini juga tidak baik karena 

senyawa dengan nilai Log P terlalu negatif tidak dapat melewati membran lipid 

bilayer (Weni dkk., 2020, Sinurat dkk., 2021). 

 

 

 

2.6. Prediksi Absorpsi, Distribusi dan Toksisitas 

 

 

Senyawa kandidat obat harus memiliki profil absorpsi dan distribusi yang baik 

dan tidak bersifat toksik bagi tubuh.  Parameter absorpsi terdiri dari nilai Human 

Intestinal Absorption (HIA) dan permeabilitas terhadap sel Caco-2 (Cancer coli), 

untuk parameter distribusi dapat dilihat dari Protein Plasma Binding (PPB) dan 

untuk parameter toksisitas terdiri dari sifat karsinogenik dan mutagenik 

(Rahmawaty dkk., 2022). 

 

Adapun kriteria yang dapat digunakan untuk membantu dalam memprediksi profil 

absorpi dan distribusi senyawa kandidat obat, yaitu sebagai berikut.  Kriteria 

absorpsi HIA, yaitu apabila nilai HIA senyawa 0-20% menunjukkan senyawa 

akan diserap dengan buruk, nilai HIA 20-70% menunjukkan senyawa akan 

diserap dengan cukup baik dan apabila nilai HIA 70-100 % menunjukkan 

senyawa akan diserap dengan baik.  Kriteria absorpsi permeabilitas terhadap sel 

Caco-2, yaitu apabila kemampuan permeabilitas senyawa < 4 nm/detik 
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menunjukkan kemampuan pemeabilitas yang rendah, kemampuan permeabilitas 

senyawa 4 -70 nm/detik menunjukkan kemampuan permeabilitas yang sedang dan 

kemampuan permeabilitas senyawa > 70 nm/detik menunjukkan kemampuan 

permeabilitas yang tinggi.  Kriteria distribusi PPB, yaitu apabila nilai PPB lebih 

dari 90% menunjukkan ikatan protein yang kuat dan apabila nilai PPB kurang dari 

90% menunjukkan ikatan protein yang lemah (Benet et al., 2016, Pratama dkk., 

2020). 

 

 

 

2.7. Penambatan Molekul (Molecular Docking) 

 

 

Penelitian menggunakan komputer atau secara kompuasi saat ini telah menjadi 

salah satu pilihan bagi para peneliti untuk melakukan penelitianya.  Penelitian 

secara komputasi atau In Silico memiliki beberapa keunggulan diantaranya seperti 

mengurangi biaya dan menghemat waktu penelitian, serta dengan mengunakan 

salah satu metode kompuasi yang disebut Molecular Docking, interaksi ikatan 

antara obat dengan target obat (reseptornya) juga dapat diamati (Agistia dkk., 

2013).  Molecular Docking atau penambatan molekul adalah sebuah metode 

penelitian secara komputasi dengan cara menambatkan suatu senyawa kandidat 

obat kepada target obat sehingga akan terjadi sebuah interaksi berupa ikatan-

ikatan kimia yang dapat digambarkan dan akan memberikan informasi aktivitas 

senyawa obat berupa potensi atau tidaknya senyawa tersebut yang dapat dilihat 

dari nilai skor docking setelah penambatan miolekul dilakukan (Arba, 2019). 

 

Suatu senyawa atau kandidat obat dalam penambatan molekul lebih dikenal 

sebagai ligan, sedangkan target obatnya dikenal sebagai protein.  Pada umunya 

ligan dalam penambatan molekul digambarkan sebagai entitas yang fleksibel atau 

bebas bergerak, sedangkan proteinnya digambarkan sebagai entitas yang tidak 

fleksibel (rigid/bersifat kaku).  Hal penting lainnya yang perlu diketahui adalah 

bahwa dalam metode ini penambatan molekul biasanya dilakukan secara in vacuo, 

yaitu dilakukan dalam kondisi tanpa air. Berdasarkan kondisi fisiologis tubuh, 

sebenarnya hal ini tidak sesuai, tetapi jika melibatkan molekul air beban 

perhitungan yang dilakukan ketika metode berjalan akan sangat besar dan 
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memakan waktu yang lebih lama.  Penambatan molekul biasanya dilakukan untuk 

skrining senyawa dalam jumlah besar dan apabila melibatkan molekul air akan 

membuatnya menjadi tidak praktis digunakan (Arba, 2019). 

 

Pada penambatan moleklul terdapat beberapa faktor penting yang perlu dilakukan 

sebelum menjalankan simulasi, yaitu: 

 

 

 

2.7.1. Pemilihan dan Preparasi Protein 

 

 

Pencarian protein target dapat dilakukan melalui situs Protein Data Bank (PDB). 

Terdapat sekitar 140.000 lebih struktur tiga dimensi protein yang dihasilkan 

melalui penelilitian menggunakan metode penentuan struktur kristalografi sinar-

X, spekstroskopi NMR dan metode lainnya.  Pencarian struktur protein target 

yang diinginkan dapat dilakukan berdasarkan pada resolusi sinar-X yang tertera. 

Pemilihan yang disarankan adalah struktur protein dengan resolusi kurang dari 

2Ả.  Struktur protein yang telah dipilih, kemudian harus dilakukan preparasi. 

Preparasi struktur protein dilakukan dengan cara menghilangkan moleklul air dan 

menambahkan atom hidrogen. Atom hidrogen ditambahkan karena berdasarkan 

hasil eksperimen sinar-X struktur protein biasanya tidak mengandung atom 

hidrogen.  Preparasi struktur protein diakhiri dengan memisahkan ligan asli 

(native ligand) dari protein tersebut karena pada struktur protein hasil eksperimen 

biasanya terdapat satu atau lebih suatu ligan aslinya. 

 

 

 

2.7.2. Pemilihan dan Preparasi Ligan 

 

 

Preparasi ligan asli (native ligand) pada penambatan molekul dilakukan dengan 

cara memisahkan struktur ligan asli dari protein dan menambahkan atom hidrogen 

pada strukturnya.  Struktur dari ligan asli ini diperlukan untuk prosedur validasi 

metode penambatan molekul yang digunakan dan apabila metode penambatan 

molekul yang digunakan valid. Selanjutnya, dapat dilakukan preparasi ligan 

sampel atau senyawa kandidat obat. 
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Pencarian senyawa kandidat obat dari bahan alam disarankan merupakan senyawa 

yang mudah ditemukan dan pemilihan dari berbagai senyawa tersebut dapat 

dilakukan dengan mengikuti atran Lipinski.  Struktur dari ligan dapat diperoleh 

melalui situs yang menyediakan ligan-ligan tersebut atau dengan cara 

menggambar struktur ligan secara manual menggunakan software yang 

mendukung.  Preparasi terhadap ligan ini dilakukan dengan langkah yang sama 

seperti preparasi ligan asli. 

 

 

 

2.7.3. Validasi Metode Penambatan Molekul 

 

 

Penambatan molekul antara ligan dengan protein tidak dapat langsung dijalankan 

setelah preparasi keduanya dilakukan. Metode penambatan molekul harus terlebih 

dahulu dilakukan validasi dengan cara redocking, yaitu menambatkan kembali 

ligan asli protein kepada proteinnya. Hal ini bertujuan untuk melihat apakah 

dengan metode yang digunakan ligan asli tersebut dapat terikat dan menempati 

posisi yang sama dengan keadaan struktur protein aslinya ketika struktur protein 

diunduh. Dalam hal ini, parameter yang digunakan untuk menilai hal tersebut 

adalah RMSD (root mean square deviation), dimana metode penambatan dapat 

dikatakan valid apabila nilai RMSD antara komformasi ligan asli dengan 

komformasi ligan hasil redocking memiliki nilai maksimal 2 Ả. Semakin kecil 

nilai RMSD maka protokol penambatan molekul yang dilakukan semakin baik. 
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III. METODE PENELITIAN 

 

 

 

 

3.1. Waktu dan Tempat 

 

 

Penelitian ini dilakukan pada bulan Agustus 2022- Februari 2023.  Pemodelan 

senyawa dilakukan dengan menggunakan pendekatan komputasi Molecular 

Docking di Laboratorium Kimia Anorganik/Fisik Universitas Lampung. 

 

 

 

3.2. Alat dan Bahan 

 

 

Alat-alat yang digunakan dalam penelitian ini adalah Laptop Lenovo dengan 

spesifikasi sistem operasi windows 10 Pro 64-bit, Processor Intel(R) Core(TM) 

i3-7020U CPU @ 2.30GHz, RAM 4GB, software PLANTS, MarvinSketch 5.2.5.1, 

YASARA 12.2.22, mingwm.dll, cmd, LigPlus dan  PyMol. 

 

Bahan-bahan yang digunakan dalam penelitian ini adalah struktur 3 dimensi 

enzim DPP-4 yang diunduh dari website Protein Data Bank dengan ID: 4n8e dan 

struktur 3 dimensi senyawa turunan genistein yang dikonstruksi menggunakan 

MarvinSketch 5.2.5.1. 

 

 

 

3.3. Prosedur Kerja 

 

 

Adapun prosedur kerja pada penelitian ini mengikuti prosedur kerja yang 

dilakukan oleh Tegar dan Purnomo. Mulai dari langkah kerja validasi metode 

hingga langkah kerja molecular docking (Tegar dan Purnomo, 2013). 
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3.3.1. Validasi Metode 

 

 

1. Preparasi Enzim DPP-4 (Protein) 

 

 

Pemodelan struktur protein dilakukan dengan menggunakan softeare YASARA.  

Buka file enzim DPP-4 dengan ID: 4n8e (File>Load>PDB file>4n8e.pdb).  

Setelah struktur protein terlihat pada jendela YASARA, dilakukan seleksi terhadap 

beberapa bagian dari protein, karena pada protokol molecular docking beberapa 

bagian tidak diperlukan.  Struktur protein 4n8e.pdb terdiri dari 2 rantai yaitu rantai 

A dan rantai B dengan susunan residu asam amino yang sama, maka untuk 

melanjutkan pada tahap molecular docking dapat dipilih satu rantai saja dan hapus 

rantai lainnya, dalam hal ini dipilih rantai B 

(Edit>Delete>Molecule>Squence;klik semua sequence A>Name;A>Belongs to or 

has;All>OK).  Selanjutnya, hapus molekul air yang ada (Edit>Delete>Waters).  

Pada protein 4n8e.pdb juga terdapat ion sulfat (ID: So4) dan karbohidrat 2-

acetamido-2-deoxy-beta-D-glucopyranose (ID: Nag), hapus keduanya 

(Edit>Delete>Residue>Squence;klik semua sequence Nag dan So4>Name;Nag 

dan So4>Belongs to or has;All>OK).  Setelah selesai, hanya akan tersisa struktur 

protein dan ligan bawaan atau ligan asli (native ligand) dengan ID: 2kv, pada 

kedua struktur tersebut, tambahkan hidrogen (Edit>Add>Hydrogens to:All) dan 

simpan sebagai YASARA Object dengan nama file “4n8e.yob” (File>Save 

as>YASARA Object).  Untuk tahap preparasi Enzim DPP-4 hanya dibutuhkan 

struktur protein maka struktur ligan asli (native ligand) dapat dihapus 

(Edit>Delete>Residue>Squence;2kv >Name;2kv>Belongs to or has;All>OK).  

Simpan struktur protein dengan format “.mol2” dan beri nama file sebagai 

“protein.mol2” (Load>Save as>Other file format>Format;mol2-Sybyl Mol2). 

 

 

 

2. Preparasi Inhibitor Enzim DPP-4 (Native Ligand) 

 

 

Preparasi struktur Native Ligand diawali dengan mambuka file YASARA Object 

pada softeare YASARA (File>Load>YASARA Object>4n8e.yob).  File ini terdiri 
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dari struktur protein dan Native Ligand , untuk mendapatkan struktur Native 

Ligand, maka struktur protein dapat dihapus (Edit>Delete>Residue>Squence;2kv 

>Name;2kv>Belongs to or has;All>beri centang pada Negate attribute>OK).  

Simpan dengan format “.mol2” dan beri nama file sebagai “ref_ligand.mol2” 

(Load>Save as>Other file format>Format;mol2-Sybyl Mol2).  Selanjutnya, buka 

software Marvinsketch dan buka file “ref_ligand.mol2” (Open> ref_ligand.mol2), 

lakukan optimasi pada struktur Native Ligand agar sesuai dengan suasana pH 

tubuh (Structure>Clean 2D>Clean in 2D) lalu (Tools>Protonation>Major 

Microspecies>at pH;7.4>OK), simpan struktur dengan format “.mrv” dan beri 

nama file sebagai “ligand_2D.mrv” (Save as>Files of Type;.mrv).  Bersihkan 

jendela kerja Marvinsketch dan buka file ligand_2D.mrv, lakukan optimasi 

konformasi pada struktur dan jadikan 10 konformasi 

(Tool>Conformatios>Conformers>Maximum number of conformers;10>OK) , 

simpan struktur dengan format “.mol2” dan beri nama file sebagai “.ligand.mol2” 

(File>Save as>Files of Type;.mol2). 

 

 

 

3. Re-docking Native Ligand dengan Enzim DPP-4 

 

 

Protokol molecular docking pada tahap validasi metode atau dapat disebut juga 

sebagai Re-docking dilakukan dengan menggunakan software PLANTS dan 

bantuan cmd (command prompt) untuk menuliskan script perintah.  Tahap awal 

dari protocol molecular docking adalah mencari koordinat titik sisi aktif/sisi 

pengikatan dari protein, sisi dimana native ligand akan berinterkasi terhadap 

protein nantinya.  Buka software cmd dan ketikkan perintah “plants --mode bind 

ref_ligand.mol2 5 protein.mol2” lalu tekan enter.  Data koordinat yang muncul 

dengan menggunakan software PLANTS berupa bindingsite_center dan 

bindingsite_radius, salin koordinat tersebut dan letakkan pada script perintah 

docking lalu simpan dan beri nama sebagai “pc_4n8e.txt”.  Dengan data koordinat 

yang sudah ada, jalankan (running) proses molecular docking, kembali ke 

software cmd dan ketikkan perintah “plants --mode screen pc_4n8e.txt” lalu tekan 

enter.  Setelah proses selesai, untuk menyimpan data skor docking dari 10 
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konformasi Native Ligand, ketikkan “cd results” lalu enter dan ketikkan “more 

bestranking.csv”.  Pilih satu struktur konformasi native ligand paling stabil yang 

memiliki skor docking terendah dan simpan file tersebut. 

 

 

 

4. Menghitung Nilai RMSD 

 

 

Parameter nilai RMSD (root mean square deviation) dilakukan dengan 

membandingkan struktur native ligand sebelum dan setelah dilakukannya protokol 

molecular docking.  Nilai RMSD dihitung dengan menggunakan software 

YASARA.  Buka struktur native ligand sebelum docking (File>Load>Other file 

format>ref_ligand.mol2), buka juga struktur native ligand setelah docking (ligand 

re-docking) (File>Load>Other file format>”entry_x”.mol2).   Hapus keberadaan 

hidrogen dari kedua struktur (Edit>Delete>Hydogens) lalu lakukan perhitungan 

nilai RMSD (Analyze>RMSD of>Objects>Sequence;ref_ligand>Name; 

ref_ligand>Belong to or has;All>OK> 

Sequence;”entry_x”>Name;”entry_x”>Belong to or has;All>OK>Return 

RMSDs per;Object>OK). 

 

 

 

5. Visualisasi 

 

 

Visualisasi 2D interaksi hasil re-docking dapat dilihat dengan terlebih dahulu 

menyatukan struktur protein dan ligand re-docking menggunakan software 

PyMOL.  Buka file protein, ketikkan “load protein.mol2” lalu buka file native 

ligand sesudah protokol molecular docking (ligand re-docking) yang paling stabil, 

ketikkan “load ‘entry_x’.mol2”.  Satukan kedua struktur dan simpan dengan 

format “.pdb” dengan cara ketikkan “save 4n8e_complex.pdb, protein +”entry_x” 

lalu tekan enter. 

 

Analisis dari interaksi yang antara ligand re-docking terhadap protein dilakukan 

dengan menggunakan software Ligplus.  Buka file ligand re-docking 

(File>Open>PDB file>Browse>4n8e_complex.pdb), akan terlihat interkasi yang 
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terjadi dan untuk membandingkannya dengan interaksi native ligand sebelum 

docking, buka file native ligand (File>Open>PDB file>Add>Browse>4n8e.pdb). 

 

 

 

3.3.2. Molecular Docking 

 

 

Protokol molecular docking untuk senyawa sampel dan senyawa pembanding, 

menggunakan struktur protein yang sama dengan struktur protein pada tahap 

validasi metode. Oleh karena itu, pada tahap ini dapat dilanjutkan langsung ke 

langkah preparasi ligan.  

 

1. Preparasi Ligan Sampel dan Ligan Pembanding 

 

 

Preparasi struktur ligan sampel (senyawa turunan genistein) diawali dengan 

mambuka software Marvinsketch lalu gambarkan struktur dari ligan. Selanjutnya, 

lakukan optimasi pada struktur agar sesuai dengan suasana pH tubuh 

(Structure>Clean 2D>Clean in 2D) dan (Tools>Protonation>Major 

Microspecies>at pH;7.4>OK).  Simpan struktur dengan format “.mrv” dan beri 

nama file sebagai “ligand_2D.mrv” (Save as>Files of Type;.mrv).  Bersihkan 

jendela kerja Marvinsketch dan buka file ligand_2D.mrv, lakukan optimasi 

konformasi pada struktur dan jadikan 10 konformasi 

(Tool>Conformatios>Conformers>Maximum number of conformers;10>OK) , 

simpan struktur dengan format “.mol2” dan beri nama file sebagai “.ligand.mol2” 

(File>Save as>Files of Type;.mol2).   

 

 

 

2. Molecular Docking Ligan Sampel dan Ligan pembanding dengan Enzim 

DPP-4 

 

 

Protokol molecular docking dilakukan dengan menggunakan software PLANTS 

dan bantuan cmd (command prompt) untuk menuliskan script perintah.  Karena 

struktur protein yang digunakan sama dengan struktur protein pada tahap validasi 
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metode maka sisi aktif/sisi pengikatan juga menggunakan koordinat titik yang 

sama sehingga langkah selanjutnya yang dilakukan adalah running proses 

molecular docking.  Jalankan (running) proses molecular docking, dengan cara 

membuka software cmd dan ketikkan perintah “plants --mode screen pc_4n8e.txt” 

lalu tekan enter, setelah proses selesai, simpan data skor docking dari 10 

konformasi ligan sampel, ketikkan “cd results” lalu enter dan ketikkan “more 

bestranking.csv”.  Pilih satu struktur konformasi ligan paling stabil yang memiliki 

skor docking terendah dan simpan file tersebut.  

 

 

 

3. Visualisasi 2D dan 3D 

 

 

Visualisasi 2D dan 3D interaksi hasil molecular docking dapat dilihat dengan 

terlebih dahulu menyatukan struktur protein dan genistein menggunakan software 

PyMOL.  Buka file protein, ketikkan “load protein.mol2” lalu buka file ligan yang 

paling stabil, ketikkan load “ligan_entry_x”.mol2.  Kemudian satukan kedua 

struktur dan simpan dengan format “.pdb” dengan cara ketikkan “save 

4n8e_ligan.pdb, protein + “ligan_entry_x” lalu tekan enter. 

 

Analisis dari interaksi yang antara genistein terhadap protein berdasarkan 

visualisasi 2D dapat dilakukan dengan menggunakan software Ligplus.  Buka file 

ligan (File>Open>PDB file>Browse>4n8e_ligan.pdb), akan terlihat interkasi 

yang terjadi.  Untuk visualisasi 3D dapat dilakukan dengan menggunakan 

software PyMOL, hubungkan software PyMOL dengan software LigPlus lalu klik 

ikon PyMOL pada jendela LigPlus sehingga jendela software PyMOL akan 

terbuka dan visualisasi 3D dari interaksi ligan dengan protein akan terlihat. 

 

 

 

3.3.3. Analisis Farmakokinetik 

 

 

Prediksi toksisitas ligan sebagai kandidat obat dilakukan secara online dengan 

menggunakan situs yang mendukung analisis ligan.  Situs pengujian aturan 
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Lipinski menggunakan situs http://www.swissadme.ch/.  Analisis ligan pada situs 

ini dilakukan dengan cara menggambar struktur ligan secara manual pada kotak 

yang telah disediakan lalu klik “Run!”. Setelah itu, data yang diperlukan akan 

muncul.   

 

Prediksi absorpsi dan distribusi ligan sampel dilakukan melalui situs pengujian 

preadme https://preadmet.webservice.bmdrc.org/.  Analisis ligan pada situs ini 

dilakukan dengan cara menggambar struktur ligan secara manual pada kotak yang 

telah disediakan lalu klik “submit”. Setelah itu, data yang diperlukan akan muncul.   

 

Prediksi toksisitas ligan sampel dilakukan melalui situs pengujian protox 

https://tox-new.charite.de/protox_II/. Analisis ligan pada situs ini dilakukan 

dengan cara klik centang pada kotak karsinogenik, imunotoksitas, mutagenitas 

dan sitotoksitas menggambar struktur ligan secara manual pada kotak yang telah 

disediakan lalu klik “Start Tox-Prediction”. Setelah itu, data yang diperlukan akan 

muncul. 

 

 

 

3.4. Diagram Alir 

 

 

Adapun diagram alir ringkasan prosedur kerja validasi metode dan molecular 

docking sebagai berikut. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.swissadme.ch/
https://preadmet.webservice.bmdrc.org/
https://tox-new.charite.de/protox_II/
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3.4.1. Diagram Alir Validasi Metode 

 

 

 Enzim DPP-4 (4n8e.pdb)  

 - dibuat file dengan format .yob 

 4n8e.yob  
 

- dipisahkan  native ligand (2kv) dari 

enzim dpp-4 

 - disimpan dengan  

format .mol2 

- disimpan dengan 

format .mol2 

 
protein.mol2 

  

 

ref_ligand.mol2  

(native ligand/2kv) 

 

 

 

 
 

- dibuat file dengan 

format .mrv 

   ligand_2d.mrv  

  
 

- disimpan dengan 

format .mol2 

 ligand.mol2  

 
 

- dilakukan proses re-docking 

 

 

konformasi ligan paling stabil.mol2 

(ligand re-docking) 

 

 

 
 

- dilakukan 

perhitungan nilai 

RMSD 

 

- dilakukan analisis 

hasil 

 
Nilai RMSD 

 

 
 Hasil analisis 
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3.4.2. Diagram Alir Molecular Docking 

 

 

 Ligan Sampel  
 

- dibuat file dengan format .mrv 

 ligand_2d.mrv  

 
 

- dibuat file dengan format .mol2 

ligand.mol2  

 - dilakukan proses docking dengan 

enzim dpp-4 (protein.mol2) 

 

 

konformasi ligan 

paling stabil.mol2 

 

 

  - dilakukan analisis hasil 

 

Hasil analisis  
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V. KESIMPULAN DAN SARAN 

 

 

 

 

5.1. Kesimpulan 

 

 

Berdasarkan penelitian yang telah dilakukan, dapat diambil simpulan sebagai 

berikut. 

 

1. Ligan D berinteraksi pada sisi aktif protein dengan membentuk 1 ikatan 

hidrogen terhadap asam amino Glu206 dan mampu membentuk ikatan 

hidrofobik lebih banyak dari ligan sampel lain.  Ligan E berinteraksi pada sisi 

aktif protein dengan membentuk ikatan hidrogen dan ikatan hidrofobik yang 

sama dengan ligan genistein.  Ligan F berinteraksi pada sisi aktif protein 

dengan membentuk 2 ikatan hidrogen terhadap asam amino Glu206 dan 

Tyr662, serta mampu membentuk ikatan hidrofobik sedikit lebih banyak dari 

ligan C dan E. 

 

2. Ligan sampel B, C, D dan F menempati posisi sisi aktif protein dengan baik 

dan mampu berinteraksi dengan residu asam amino Glu205, Glu206 dan 

Tyr662 membentuk ikatan hidrogen, serta residu asam amino sisi aktif lainya 

untuk membentuk ikatan hidrofobik. 

 

3. Senyawa turunan genistein yang memiliki potensi terbaik sebagai antidiabetes 

adalah ligan F (5-hydroxy-3-(4-hydroxyphenyl)-7-methoxy-4H-chromen-4- 

One) yang merupakan hasil modifikasi gugus hidroksil posisi ke-7 dari struktur 

gensitein menjadi gugus metoksi (-OCH3) dengan skor docking sebesar -

78.5436. 
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4. Ligan F menunjukkan potensi farmakokintetik terbaik dibandingkan ligan 

sampel lainnya, dimana ligan F diprediksi dapat terabsorpsi dan terdistribusi 

dengan sukup baik, serta tidak bersifat toksik. 

 

 

 

5.2. Saran 

 

 

Berdasarkan hasil penelitian yang telah diperoleh, diharapkan kepada peneliti 

selanjutnya untuk melakukan uji molecular docking terhadap turunan genistein 

lainnya dengan penggantian gugus hidroksil posisi C ke-4’ dan C ke ke-5 untuk 

melihat potensinya sebagai antidiabetes. 
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