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ABSTRAK 

PEMODELAN QUANTITATIVE STRUCTURE AND ACTIVITY 

RELATIONSHIP (QSAR) SEBAGAI UJI AKTIVITAS ANTIDIABETES 

SENYAWA KOMPLEKS Fe(II), Zn(II), Mn(II), dan Mg(II) DENGAN 

ASAM AMINO SISTEIN SECARA IN SILICO PADA PROTEIN 5KQG 

 

 

Oleh 

 

ANISA CIKAL AMARTA 

 

Diabetes Melitus (DM) adalah penyakit endokrin utama dan masalah kesehatan 

yang terjadi karena peningkatan kadar glukosa dalam tubuh.  Pengobatan berbasis 

logam kompleks telah banyak dikembangkan dan dapat digunakan sebagai 

kandidat antidiabetes.  Penelitian ini dilakukan dengan menambatkan molekul 

senyawa [Fe(cys)2], [Zn(cys)2], [Mn(cys)2], dan [Mg(cys)2] melalui studi 

molecular docking untuk mengetahui energi Gibbs senyawa kompleks terhadap 

protein target. Validasi native ligand menunjukkan hasil RMSD sebesar 1.818 Å 

dengan nilai docking sebesar -11.91 Kkal/mol. Senyawa [Fe(cys)2], [Zn(cys)2], 

[Mn(cys)2], dan [Mg(cys)2] menghasilkan skor docking secara berturut-turut 

sebesar -5.08; -5.48; -5.12; dan -5.37 Kkal/mol. Visualisasi 3D dengan software 

Discovery Studio Visualizer menunjukkan [Fe(cys)2] dengan skor docking lebih 

negatif dari senyawa pembanding Metformin (-2.77 Kkal/mol) memiliki jumlah 

kesamaan ikatan pada asam amino sisi aktif protein target dengan kontrol yaitu 

GLY14, TYR131, CYS17, ILE16, dan ARG18. Analisis dilanjutkan dengan uji 

Farmakokinetik dan Toksisitas untuk kandidat obat menggunakan metode in silico 

untuk menentukan kandungan senyawa sebagai kandidat obat antidiabetes 

tersebut secara Lipinski Rule of Five, Pre-ADME, dan Protox. Penelitian ini juga 

bertujuan memodelkan senyawa [Fe(cys)2], [Zn(cys)2], [Mn(cys)2], dan 

[Mg(cys)2] untuk mencari konformasi senyawa yang memiliki nilai IC50 terhadap 

enzim Low Molecule Weight  Protein Tyrosine Phosphatase (LMW-PTP). Hasil 

yang pada penelitian ini menunjukkan bahwa [Fe(cys)2] dengan nilai Log IC50 

perhitungan sebesar -2.07 atau nilai IC50 perhitungan sebesar 0.01 μ M berpotensi 

untuk dijadikan sebagai kandidat obat antidiabetes dalam menggantikan 

Metformin. 

 

Kata kunci: Antidiabetes, molecular docking, senyawa kompleks, QSAR 



 

 

 
 

ABSTRACT 

QUANTITATIVE STRUCTURE AND ACTIVITY RELATIONSHIP 

(QSAR) MODELING AS AN ANTIDIABETIC ACTIVITY TEST OF 

Fe(II), Zn(II), Mn(II), AND Mg(II) COMPLEX COMPOUNDS WITH 

CYSTEINE AMINO ACID IN SILICO ON PROTEIN 5KQG 

 

 

By 

 

ANISA CIKAL AMARTA 

 

 

Diabetes Mellitus (DM) is a major endocrine disease and health issue caused by 

elevated glucose levels in the body. Metal complex-based treatments have been 

extensively developed and can be used as antidiabetic candidates. This research 

involved docking molecules of the compounds [Fe(cys)2], [Zn(cys)2], [Mn(cys)2], 

dan [Mg(cys)2] through molecular docking studies to determine the Gibbs energy 

of the complex compounds against the target protein. Validation of the native 

ligand showed an RMSD result of 1.818 Å with a docking score of -11.91 

Kcal/mol. The compounds [Fe(cys)2], [Zn(cys)2], [Mn(cys)2], dan [Mg(cys)2] 

produced docking scores of -5.08; -5.48; -5.12; and -5.37 Kcal/mol, respectively. 

3D visualization using Discovery Studio Visualizer software showed that 

[Fe(cys)2] with a more negative docking score than the comparator compound 

Metformin (-2.77 Kcal/mol) had similar binding sites on the active site amino 

acids of the target protein, namely GLY14, TYR131, CYS17, ILE16, and ARG18. 

The analysis continued with pharmacokinetic and toxicity tests for the drug 

candidates using in silico methods to determine the compound content as 

antidiabetic drug candidates based on the Lipinski Rule of Five, Pre-ADME, and 

Protox. This study also aimed to model the compounds [Fe(cys)2], [Zn(cys)2], 

[Mn(cys)2], dan [Mg(cys)2] to find the conformation of the compounds that have 

an IC50 value against the enzyme Low Molecule Weight Protein Tyrosine 

Phosphatase (LMW-PTP). The results obtained are research shows that [Fe(cys)2] 

with a predicted Log IC50 value of -2.07 or a predicted IC50 value of 0.01 μM has 

the potential to be used as an antidiabetic drug candidate to replace Metformin. 

Keywords: Antidiabetic, molecular docking, complex compounds, QSAR 
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I. PENDAHULUAN 

1.1 Latar Belakang 

 

Diabetes melitus adalah penyakit metabolik serius yang menyerang jutaan orang 

di seluruh dunia (ADA, 2019).  Diabetes melitus termasuk penyebab utama 

penyakit jantung, stroke, gagal ginjal, kebutaan, dan amputasi tungkai bawah 

(Isnaini dan Ratnasari, 2018).  World Health Organization (WHO, 2023) telah 

melaporkan bahwa terdapat sekitar 422 juta orang diseluruh dunia menderita 

diabetes, bahkan diperkirakan secara global jumlah penderita diabetes melitus 

rentang usia 20 hingga 79 tahun akan meningkat dari 415 juta pada tahun 2015 

menjadi 642 juta pada tahun 2040.  Diabetes melitus merupakan penyakit kronis 

yang menyebabkan multi komplikasi hingga kematian (Fauza et al., 2023).  

Pemanfaatan obat dari logam semakin klinis dan komersial, karena lebih dari 2 

hingga 8% populasi dunia menderita penyakit diabetes.  Peningkatan jumlah 

penderita diabetes telah memberikan dorongan untuk penelitian dan 

pengembangan dalam memanfaatkan potensi terapeutik logam agar dapat 

menghasilkan terapi baru yang lebih efektif dan aman untuk mengatasi tantangan 

kesehatan yang dihadapi oleh populasi penderita diabetes yang terus meningkat 

(Sudha and Askar, 2022).  Korelasi antara diabetes dan ketidakseimbangan logam 

membuat terapi berbasis logam menjadi alternatif yang meyakinkan.  

Pengembangan kompleks logam antidiabetes mampu menggantikan injeksi 

insulin yang mengatur kadar gula (Pandey et al., 2012).  Metallotherapy adalah 

strategi baru pengembangan kompleks logam yang digunakan pada pengobatan 

berbagai penyakit seperti diabetes, artritis rheumatoid, penyakit inflasi dan 

kardiovaskular serta agen diagnostik (Bharti dan Singh, 2009).  
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Logam, keadaan oksidasi, jumlah ligan, jenis ligan, dan geometri koordinasi 

kompleks memberikan berbagai sifat karena memberikan peran penting dalam 

menentukan sifat interaksi yang terlibat dalam identifikasi target biologis seperti 

DNA, enzim, dan reseptor protein (Pattan et al., 2012). 

Senyawa kompleks logam telah banyak disintesis untuk mengatasi masalah 

injeksi insulin yang menyakitkan dan memberikan efek samping untuk diabetes 

melitus tipe 1 atau 2.  Perkembangan penelitan logam Cr, Mn, Mo, Fe, Cu, Co, 

Zn, dan V telah dilaporkan menunjukkan sifat insulin-mimetik atau meningkatkan 

sifat insulin dalam kondisi in vitro dan in vivo (Hiromura and Sakurai, 2016).  

Mekanisme antidiabetes yang terjadi diantaranya adalah efek insulin (Cr, Mg), 

efek antioksidan (Co, Mn, Zn), penghambatan enzim fosfatase (Vanadium), 

stimulasi pengambilan glukosa, glikogen, dan sintesis lipid dalam otot, 

penghambatan glukoneogenesis (Cr, Co), hingga stimulasi aktivitas 

glukoneogenik (Mn) (Thompson and Orvig, 2016). 

Kompleks seng (Zn)  telah diusulkan untuk menjadi kandidat baru dalam 

mengobati diabetes.  Seng adalah komponen alami dari insulin, zat ini sangat 

penting untuk pengaturan metabolisme gula pada makhluk hidup.  Seng memiliki 

aksi yang mirip dengan insulin dalam merangsang penyerapan glukosa oleh 

jaringan adiposa (Yoshikawa and Yasui, 2012). 

Mangan (Mn) memiliki peran penting dalam sejumlah proses fisiologis untuk 

metabolisme karbohidrat, asam amino, dan kolesterol.  Turunan sintesis dari 

mangan ditemukan dapat digunakan sebagai agen terapeutik yang ampuh pada 

diabetes (Olcott et al., 2014).  Kadar Fe yang tinggi mengoksidasi berbagai 

biomolekul seperti asam nukleat, protein, dan lipid yang dapat berperan pada 

perkembangan diabetes melitus dengan mengurangi sekresi insulin dari sel β dan 

pankreas dengan pengingkatan resistensi insulin yang terjadi secara bersamaan 

(Abu-Dief et al., 2023).  Magnesium (Mg) merupakan kofaktor yang diperlukan 

untuk perpindahan glukosa ke dalam sel dan untuk metabolisme karbohidrat. 

Magnesium terlibat dalam aktivitas seluler insulin, asupan magnesium yang 

rendah menjadi faktor penyebab diabetes (Lopez et al., 2014).  Kekurangan 

magnesium dapat menghambat pertahanan sel terhadap kerusakan oksidasi 
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sehingga dapat mempercepat perkembangan komplikasi terkait diabetes (Hata et 

al., 2013). 

 

Metode komputasi atau disebut juga in silico merupakan suatu studi interaksi serta 

prediksi afinitas senyawa yang didasarkan pemodelan simulasi docking senyawa 

uji dengan molekul target dan prediksi toksisitas dari senyawa uji (Fakih dkk., 

2021).  Metode ini dilakukan untuk mencari konformasi dari interaksi dan afinitas 

terbaik senyawa uji pada sisi aktif reseptor protein target (Erukainure et al., 2023).   

Sedangkan prediksi toksisitas bertujuan untuk menilai resiko munculnya toksisitas 

dari senyawa uji yang dapat berdampak bagi manusia (Adelina, 2014).  Kimia 

komputasi menjadi salah satu cabang ilmu kimia yang mempelajari sifat-sifat 

suatu molekul dengan perangkat lunak atau perangkat keras yang berfokus pada 

pemecahan masalah melalui perhitungan (Jensen, 2017).  Objek kajian yang 

digunakan ialah struktur molekul atau atom dengan dimensi subanometer 

(berukuran 10
-10

 m) yang belum dapat diselesaikan dengan pendekatan mekanika 

klasik (Thomas, 2013).   

 

Kimia komputasi mampu mengkaji molekul atau atom hingga menjangkau ke 

skala mikroskopis sehingga sangat mendukung penelitian dalam bidang farmasi 

yang bertumpu pada indeks kemoterapi dengan menyatakan nilai efektivitas obat 

yang kini dinyatakandengan istilah Quantitative Structure and Activity 

Relationship (QSAR) atau dikenal juga dengan istilah Hubungan Kuantitatif 

Struktus dan Aktivitas (HKSA) (Purnomo, 2018).  Perkembangan eksperimen 

komputer dapat memungkinkan perhitungan sifat molekul yang kompleks dengan 

hasil yang berhubungan dengan hasil yang relevan dengan studi eksperimen 

laboratorium (Gauraf, 2012).  Metode QSAR mampu mengingkatkan keakuratan 

dan kecepatan dalam memperoleh hasil eksperimen karena dapat menunjukkan 

interaksi molekul dengan sistem tubuh yang membutuhkan temuan senyawa obat 

untuk penyakit yang berbahaya, salah satu contohnya adalah diabetes mellitus 

(Abuhammad, 2016). 
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Penelitian dengan metode komputasi (in silico) kali ini bertujuan mengembangkan  

strategi baru pengembangan kompleks logam yang digunakan pada Fe, Zn, Mg, 

dan Mn dengan asam amino Sistein yang berikatan pada sisi aktif enzim Protein 

Tyrosine Phosphatase (PTP) dengan kode 5KQG.   

Pemilihan protein 5KQG karena termasuk kedalam Protein Tyrosine Phosphatase 

(PTP).  Protein Tyrosine Phosphatase (PTP) sangat penting karena memainkan 

peran kunci dalam mengatur sinyal insulin dan sensitivitas insulin. Insulin adalah 

hormon yang penting dalam mengendalikan kadar gula darah, dan resistensi 

insulin adalah karakteristik utama diabetes tipe 2 (Gurzov et al., 2015).  Penelitian 

(Stanford et al., 2017) menunjukkan bahwa aktivitas PTP meningkat dalam 

keadaan resistensi insulin, yang artinya bahwa PTP dapat menghambat sinyal 

insulin dengan mengurangi aktivitas enzim yang diperlukan untuk proses sinyal 

insulin, sehingga menyebabkan resistensi insulin.  Resistensi insulin adalah tahap 

awal dalam perkembangan diabetes tipe 2.  Jika resistensi insulin tidak ditangani 

dengan baik, pankreas akan terus meningkatkan produksi insulin untuk mencoba 

menurunkan kadar glukosa dalam darah, sehingga pankreas tidak dapat 

memproduksi insulin yang cukup untuk mempertahankan kadar glukosa darah 

yang normal yang menyebabkan diabetes tipe 2 (Mansi et al., 2017).  Oleh karena 

itu, pemilihan protein 5KQG yang termasuk bagian Protein Tyrosine Phosphatase 

(PTP) sebagai fokus penelitian dalam konteks diabetes didasarkan pada perannya 

dalam regulasi metabolik, potensi sebagai target terapeutik, dan kontribusinya 

dalam memahami diabetes dan komplikasinya. 

Penelitian yang telah dilakukan oleh (Ambarwati dkk., 2021), bahwa Protein 

Tyrosine Phosphatase (PTP) yang didocking dengan senyawa kompleks Cr(III)-

pilokinat dan kromat memberikan nilai energi interaksi sebesar  -7,00 kkal/mol
-1

 

dan terdapat 4 asam amino pada sisi aktif  PTP yang berinteraksi dengan ion 

[CrO4] yaitu Leu(13), Gly(14), Ile(16), Cys(17), Arg(18).  Sehingga pada 

penelitian ini, kemudian akan diamati ikatan yang terjadi, skor docking dari 

konformasi senyawa kompleks, nilai RMSD, sisi aktif ligan pada protein PTP, 

hingga visualisasi 2D dan 3D senyawa kompleks [Fe(cys)2], [Zn(cys)2], 

[Mn(cys)2], dan [Mg(cys)2] terhadap PTP 5KQG lalu dilanjutkan dengan analisis 
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farmakokinetik hingga Quatitative Structure and Activity Relationship (QSAR) 

atau disebut juga sebagai Hubungan Kuantitatif Struktur dan Aktivitas (HKSA) 

untuk didapatkan senyawa kompleks sebagai kandidat obat antidiabetes. 

 

 

1.2 Tujuan Penelitian  

 

Tujuan dari penelitian ini adalah sebagai berikut: 

1. Melakukan pemodelan potensi antidiabetes senyawa kompleks [Fe(cys)2], 

[Zn(cys)2], [Mn(cys)2], dan [Mg(cys)2] untuk mendapatkan seluruh asam 

amino yang terikat pada sisi aktif protein 5KQG menggunakan software 

Discovery Studio Visualizer 2021. 

2. Mendapatkan nilai docking  dan panjang ikatan yang terbentuk antara senyawa 

kompleks [Fe(cys) 2], [Zn(cys)2], [Mn(cys)2], dan [Mg(cys)2] pada protein 

5KQG menggunakan software AutoDockTools-1.5.6. 

3. Mengetahui tingkat toksisitas senyawa kompleks [Fe(cys)2], [Zn(cys)2], 

[Mn(cys)2], dan [Mg(cys)2]  sebagai kandidat obat antidiabetes dengan 

website Lipinski Rule of Five, Pre-ADME, dan Protox II. 

4. Memperoleh pemodelan persamaan Quantitative Structure and Activity 

Relationship (QSAR) terbaik senyawa kompleks [Fe(cys)2], [Zn(cys)2], 

[Mn(cys)2], dan [Mg(cys)2]  menggunakan analisis regresi multilinier. 

 

1.3 Manfaat Penelitian 

 

Penelitian ini diharapkan dapat memberikan manfaat dalam memberikan nilai 

interaksi senyawa kompleks [Fe(cys)2], [Zn(cys)2], [Mn(cys)2], dan [Mg(cys)2] 

terhadap Protein Tyrosine Phosphatase (PTP) dengan kode 5KQG secara in silico 

dalam model Quantitative Structure And Activity Relationship (QSAR) sehingga 

dapat dijadikan kandidat obat antidiabetes. 



 

 

 
 

II. TINJAUAN PUSTAKA 

2.1 Diabetes Melitus  

Diabetes Melitus (DM) adalah penyakit endokrin utama dan masalah kesehatan 

yang berkembang hampir diseluruh negara.  Diabetes Melitus menjadi salah satu 

penyakit penyebab kematian di dunia yang dampaknya begitu besar bagi 

kehidupan dan kesejahteraan masyarakat dalam jangka panjang (Jun-Koo Yi et 

al., 2019).  Diabetes Melitus (DM) termasuk salah satu penyakit kronis karena 

terjadi peningkatan kadar glukosa dalam tubuh akibat tidak dapat memproduksi 

hormon insulin yang cukup atau tidak dapat menggunakan insulin secara efektif 

(Saeedi et al., 2019).  Penyakit ini diklasifikasikan menjadi dua jenis yang dikenal 

sebagai jenis diabetes tipe I atau Insulin Dependent Diabetes Melitus (IDDM) dan 

tipe II atau Non Insulin Dependent Diabetes Melitus (NIDDM).  Diabetes melitus 

(DM) tidak terbatas pada kadar glukosa darah yang abnormal, tetapi dapat 

berkembang dan menyebabkan berbagai komplikasi antara lain: diabetik 

retinopati, gagal ginjal, dan diabetik neuropati peripheral (Hassanien et al., 2020). 

Indonesia merupakan negara dengan penderita DM terbanyak keempat di dunia 

setelah India, China, dan Amerika Serikat dengan penderita sebanyak 8.426.000 

dan diperkirakan menjadi 21.257.000 penderita pada tahun 2030 (WHO, 2023).  

Selain itu, persentase kematian akibat diabetes di Indonesia merupakan yang 

tertinggi kedua setelah SriLanka.  Prevalensi orang dengan diabetes di Indonesia 

menunjukkan kecenderungan meningkat yaitu 5,7% (2007) menjadi 6,9% (2013) 

(Oktorina dkk., 2019).  

Diabetes Melitus tipe-1 memiliki persentase sekitar 5-10% kasus diabetes yang 

terjadi di seluruh dunia dan disebut penyakit kronis karena diakibatkan oleh 

kurangnya insulin endogen dari sel β pankreas (Paschou et al., 2018).   



7 

 

 
 

Pada usia dewasa, kerusakan sel β pankreas lebih lambat sehingga DMT1 

didiagnosis ke usia yang lebih muda.  Menurut penelitian yang dilakukan 

(Patterson, 2018), proporsi kasus DMT1 yang didiagnosis selama masa kanan-

kanak (usia 1-14 tahun) sekitar 40 penderita dari 100.000 anak di Finlandia dan 

Sardinia. 

Diabetes melitus tipe 2 (DMT2) juga dilaporkan mengalami peningkatan pada 

usia yang lebih muda, baik pada remaja maupun anak-anak.  Kasus Diabetes 

melitus tipe 2 di Amerika Serikat, sekitar sepertiga orang yang didiagnosis adalah 

remaja (Okaiyeto et al., 2019).  DMT2 terjadi akibat gangguan metabolisme 

glukosa akibat resistensi insulin sehingga dapat berdampak pada penggunaan 

glukosa oleh otot rangka, hati, dan jaringan adiposa (Stumvoll et al., 2005).  

Faktor-faktor lain seperti genetik, faktor lingkungan, pola makan, kurangnya 

aktivitas fisik, dan obesitas secara signifikan juga berkontribusi pada 

perkembangan resistensi insulin dan perkembangan diabetes tipe 2 (Badawi et al., 

2010). 

 

Metallotherapy adalah strategi baru yang digunakan untuk pengobatan diabetes 

melitus.  Obat berbasis logam untuk mengobati diabetes dengan kompleks logam 

pertama kali dipelajari oleh Coulson dan Dandona pada tahun 1980.  Banyak 

kompleks logam telah disintesis untuk mengatasi masalah efek samping diabetes 

tipe 1 atau tipe 2 (Sudha and Askar, 2021).  Inhibitor enzim pencerna karbohidrat 

α-amilase dicari sebagai obat diabetes.  Banyak peneliti melaporkan aktivitas 

mirip insulin, α-amilase¸dan α-glukosidase penghambatan dengan kompleks ligan 

transisi yang berbeda melibatkan berbagai ligan (Ahmed et al., 2017).  Salah satu 

yang terkini adalah membuat obat antidiabetes sebagai suntikan insulin dan obat-

obatan sintesis dari berbagai sifat logam seperti Zn, Cd, Cr, V, Cu, Ti, Fe, Mg, Se, 

Mn, dan Co (Pawar et al., 2018). 

 

2.2 Sistein 

Sistein atau asam amino sistein adalah asam amino yang dapat diperodeh dari 

makanan atau diproduksi dari degradasi metionin melalui jalur transulfurasi. 

Sistein disintesis di dalam tubuh manusia dari metionin (asam amino esensial 
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yang mengandung sulfur), bentuk sistein yang paling melimpah dalam tubuh 

adalah L-sistein (Sameem et al., 2019).  Secara struktural, sistein mengandung 

sulfur atom belerang dalam rantai yang terlibat dalam pembentukan gugus 

sulfhidril (-SH) yang reaktif.  Sulfhidrasi termasuk dalam modifikasi fisiologis 

yang paling baru ditemukan dan memainkan peran yang beragam dalam fisiologi, 

mulai dari respons terhadap peradangan hingga perlindungan saraf  (Paul et al., 

2018).  

Asam amino sistein berperan dalam kinerja glucose tolerance factor (GTF) yang 

sangat penting untuk pengaturan metabolisme glukosa.  Asam amino sistein 

berfungsi sebagai komponen struktural utama GTF untuk membentuk ikatan yang 

penting terhadap aktivitas biologisnya (Roshana et al., 2018).    Diabetes sering 

dikaitkan dengan stres oksidatif yang tinggi, di mana  Reactivity of Oxygen 

Species (ROS) dapat merusak sel dan meningkatkan resistensi insulin, sistein 

sebagai prekursor glutation membantu melindungi sel dari kerusakan oksidatif, 

sehingga membantu mempertahankan fungsi insulin yang optimal (Scheen et al., 

2015).  Asam amino sistein membantu transportasi glukosa ke dalam sel tubuh 

untuk memastikan kadar gula darah tetap dalam keadaan normal.  Oleh karena itu, 

peran sistein dalam kinerja GTF tidak hanya berdampak pada regulasi langsung 

metabolisme glukosa tetapi juga pada perlindungan sel terhadap stres oksidatif, 

yang semuanya penting dalam pengelolaan dan pencegahan diabetes. 

Penelitian telah menunjukkan bahwa sistein secara independen terkait dengan 

prevalensi neuropati diabetik pada pasien diabetes secara kolektif (Rehman et al., 

2020).  Studi yang berbeda menunjukkan bahwa pada pasien diabetes, sistein 

berubah dan menghasilkan kadar sistein darah yang lebih rendah.  L-sistein dapat 

sangat dipertimbangkan dalam obat diabetes dalam pengelolaan diabetes tipe 2 

(Malaphong et al., 2022). 

 
Gambar 1. Struktur Sistein (Sameem et al., 2019). 
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2.3 Iron (Fe)  

Logam Iron atau Besi (Fe) merupakan logam transisi esensial yang diperlukan 

pada sintesis protein fungsional, seperti hemoglobin dan mioglobin yang terlibat 

langsung dalam pengangkutan oksigen molekuler selama respirasi (Sabeena et al., 

2022).  Kadar Fe yang tinggi mengoksidasi berbagai biomolekul seperti asam 

nukleat, protein, dan lipid yang berkontribusi pada perkembangan diabetes 

melitus tipe 2 dengan mengurangi sekresi insulin dari sel β pankreas yang disertai 

dengan peningkatan resistensi insulin (Jiang et al., 2004).  

Kelat logam Fe(II) menggambarkan geometri oktahedral yang telah diteliti secara 

in silico terhadap protein (PDB : 7BQY), menunjukkan kondisi energi bebas gibs 

7,1 kkal/mol untuk menentukan aktivitas antioksidan melatonin pada diabetes 

dalam kaitannya kadar plasma pada tikus Zucker Diabetic Fatty (ZDF) (Simcox 

and McClain, 2013).   

Senyawa kompleks Fe(II)-thiourea telah diketahui memiliki aktivitas antimalarial 

(Pingaew et al., 2017), antivirus (Burgeson et al., 2012), antibakteri dan 

antimikroba (Bielenica et al., 2018), antidiabetes (Navarro  et al., 2013), dan 

antituberculosis (Dogan et al., 2020).  Flavonoid dan kompleks Fe(II) yang 

disintesis dapat berinteraksi secara in vitro dengan glukosa. Logam-flavonoid 

lebih baik terhadap antidiabetes, dengan demikian semua logam kompleks dapat 

berpotensi diuji untuk aplikasi medis lebih lanjut (Abu-Dief et al., 2023). 

 

2.4  Zink (Zn) 

Peran seng (Zn) pada diabetes telah menjadi subjek yang diminati, karena sifat 

yang mirip insulin terkait dengan Zn, seperti penelitian yang dilakukan (Motloung 

et al., 2020) mengembangkan senyawa kompleks Zn(II)-asam galat disintesis 

dengan tujuan potensi antidiabetes memiliki tindakan terapeutik yang lebih baik, 

hasilnya menunjukkan bahwa kompleks yang disintesis aman sebagai antioksidan 

yang bekerja dalam kontrol glikemik nutraceutical untuk diabetes.  Secara teoritis, 

seng dapat melakukan sejumlah fungsi antioksidan tidak langsung, perlindungan 

terhadap penipisan vitamin E, stabilitas struktur membran, pembatasan radikal 
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bebas endogen produksi, memberikan kontribusi pada struktur antioksidan enzim 

superoksida (Lopez et al., 2014). 

Zn sangat penting untuk sekresi dan aktivitas insulin yang tepat pada sel pancreas, 

karena kekurangan  Zn menambah kerusakan yang diinduksi oleh sitokin sehingga 

mengakibatkan penghancuran sel pada diabetes melitus (Abdul and Fazli, 2014). 

2.5 Mangan (Mn) 

Mangan (Mn) bertindak sebagai kofaktor dalam beberapa enzim termasuk yang 

terlibat dalam metabolism karbohidrat, protein, dan lemak (Orbea et al., 2012).  

Mn termasuk kofaktor piruvat karboksilase yang berperan dalam konversi 

berbagai senyawa non-karbohidrat menjadi glukosa.  Mn juga diperlukan untuk 

sintesis insulin normal, sekresi insulin, dan perubahan metabolisme dalam 

perkembangan diabetes (Forte et al., 2013). 

Studi molecular docking membantu dalam menjelaskan cara kerja senyawa 

melalui berbagai interaksinya dengan situs aktif reseptor PI3Kγ sebagai target.  

Kompleks yang dioptimakan [M(caf)4] (PF6)2; M = Mn(II) menunjukkan afinitas 

yang baik dengan berbagai residu asam amino Lys(298), Glu(856), Asn(299), 

Arg(277), Asp(788), Pro(866), Tyr(787), Gln(846), His(295), Val(882), dan 

Arg(849) (Hamdani and Amane, 2019). 

 

2.6 Magnesium (Mg) 

Magnesium (Mg) adalah nutrisi makro yang paling melimpah untuk kesehatan 

tubuh.  Kekurangan Mg dalam tubuh dapat menyebabkan penurunan penyerapan 

glukosa yang dimediasi oleh insulin.(Mooren et al., 2011).  Selain itu, konsumsi 

Mg dapat mencegah resistensi insulin dan juga mengurangi perkembangan 

diabetes (Hosseini et al., 2018).  Para peneliti menyimpulkan bahwa magnesium 

memainkan peran penting dalam menjaga kadar glukosa darah karena magnesium 

urin dan magnesium plasma berkorelasi dengan kadar glukosa puasa (Manal et 

al., 2019). 
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Asupan magnesium yang rendah dan berkurangnya konsentrasi magnesium 

plasma dapat menyebabkan perubahan dalam kontrol glikemik karena distribusi 

mineral mempengaruhi sekresi dan aksi insulin.  Penelitian yang dilakukan 

menunjukkan hasil bahwa Mg(NO3)2-6H2O terikat pada mettallothionein di hati 

dan ginjal tikus diabetes, efek dari diabetes pada logam sangat mirip untuk 

kemudian diinduksi secara kimiawi diabetes (Sales et al., 2011). 

2.7 Metformin (C4H11N5) 

Metformin adalah salah satu obat yang paling umum digunakan untuk mengobati 

diabetes selama hampir satu abad terakhir (Flory and Lipska, 2019).   

Pada tahun 1920-an, metformin (1,1-dimetil biguane hidroklorida) telah disintesis 

dan menjadi pilihan pertama untuk mengobati diabetes karena kemampuannya 

untuk menurunkan kadar glukosa plasma (Yendapally et al., 2020).   

Dalam beberapa tahun terakhir, banyak studi yang menunjukkan bahwa peran 

metformin memberikan efek yang kuat pada berbagai jenis kanker (Morales and 

Morris, 2015), penyakit kardiovaskular (Lamanna et al., 2011), penyakit hati 

(Bhat et al., 2015), obesitas (Breining et al., 2018), dan penyakit ginjal (Neven et 

al., 2018).  

Metformin memiliki harga yang terjangkau dan cukup aman bahkan beresiko 

rendah hipoglikemia, karena tidak ada kejadian kenaikan berat badan dan sedikit 

efek samping bila obat ini dikonsumsi (Bahrambeigi  et al., 2019).  Selain itu, 

metformin menurunkan kadar insulin puasa pada pasien dengan metabolisme 

glukosa yang tidak normal (Lv and Guo, 2020).  Metformin adalah pilihan 

pengobatan yang rasional karena terbukti memiliki efek penurunan kadar glukosa 

atas dasar studi in vitro dan in vivo, termasuk studi pada hewan dan klinis uji coba 

(Bell et al., 2019). 
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Gambar 2. Struktur Metformin (Yendapally et al., 2020) 

 

2.8 Pemodelan Molekul (Molecular Modelling) 

Molecular Modelling adalah metode merancang obat dengan Computer-Aided 

Drug Design (CADD) untuk skrining virtual, optimasi hit/lead, dan desain 

senyawa baru. Dalam skrining virtual, database senyawa diperiksa untuk 

mengikat suatu target dan dilanjutkan pengujian in vitro.  Tujuan molecular 

modelling adalah meningkatkan tingkat keberhasilan obat baru dengan 

mengurangi jumlah senyawa yang akan diuji secara eksperimental (R. Feng et al., 

2019).   

Desain obat berbasis Structure Based Drug Design (SBDD) merupakan suatu 

metode yang mengambil banyaknya eksperimental struktur yang dipecahkan 

dalam Protein Data Bank (PDB) dapat membantu merasionalisasi dan 

mengoptimalkan pengikatan interaksi ligan-target (Strecker and Meyer, 2018). 

 

2.9 Penambatan Molekul (Molecular Docking) 

Molecular docking adalah metode berbasis struktur in silico yang telah banyak 

digunakan dalam penemuan obat.  Docking dapat memudahkan dalam identifikasi 

senyawa baru yang memiliki potensi terapeutik atau memprediksi interaksi ligan-

target pada tingkat molekuler.  Molecular docking dikembangkan untuk 

membantu memahami mekanisme pengenalan molekuler, sehingga pada beberapa 

tahun terakhir penggunaan dan aplikasi docking dalam penemuan obat telah 

banyak dimanfaatkan (Pinzi and Rastelli, 2019).  
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Pendekatan in silico memungkinkan penyaringan virtual jutaan senyawa dalam 

waktu yang singkat, sehingga mengurangi biaya awal identifikasi dan 

meningkatkan peluang untuk menentukan kandidat obat yang diinginkan (Fan J et 

al., 2019).  Saat ini, beberapa molekuler teknik pemodelan molekul tersedia untuk 

penemuan obat, sebagian besar diklasifikasikan menjadi pendekatan berbasis 

struktur dan berbasis ligan.  Prediksi ini menghasilkan konformasi dan pengikatan 

afinitas molekul kecil dalam prediksi minimalnya keadaan energi dan digunakan 

untuk menemukan senyawa secara virtual (Andrew et al., 2021). 

 

2.10 Protein Data Bank (PDB) 

Protein Data Bank adalah salah satu sumber biodata akses terbuka yang paling 

banyak digunakan seluruh dunia.  PDB telah terakreditasi oleh CoreTrustSeal.  

PDB digunakan oleh jutaan peneliti dasar dan terapan, pendidik, hingga 

mahasiswa karena hampir ada 200.000 struktur tiga dimensi (3D) makromolekul 

biologis (protein, asam nukleat, karbohidrat) yang diarsipkan secara konsisten, 

divalidasi secara ketat, dan diuji secara eksperimental (Stecker and Meyer, 2028). 

Akses terbuka ke data PDB tanpa batasan pengunggunaan juga memungkinkan 

bioinformatika struktural berkembang sebagai sub-disiplin biologi komputasi 

yang dinamis.  Pemodelan struktur protein homologi atau komparatif bergantung 

pada penggunaan struktur yang ditentukan secara eksperimental dengan urutan 

asam amino sebagai template pemodelan (Baker and Sali, 2020). 

Jenis Protein Tyrosine Phosphatase (PTP) yang digunakan pada penelitian ini 

adalah Low molecular weight Protein Tyrosine Phosphatase (LMW-PTP) dengan 

kode PDB 5KQG yang diunduh dari website (ww.rcbd.org) dengan detail struktur 

di bawah ini : 

Resolution: 1.50 Å 

Ligands : (1~{S})-2-(1,3-benzothiazol-2-ylamino)-2-oxidanylidene-1-phenyl-

ethanesulfonic acid (C15H12N2O4S2). 

Organism(s)   : Homo Sapiens 



14 

 

 

               
 

Gambar 3. Struktur 3D Protein 5KQG (www.rcsb.org) 

Informasi yang diperoleh pada Gambar 3a (struktur 5KQG tampak depan) dan 

Gambar 3b (struktur 5KQG tampak belakang), menunjukkan adanya ujung N 

terletak pada asam amino ALA4 yang artinya asam amino alanin adalah ujung 

awal dari rantai polipeptida.  Sedangkan ujung C terletak pada asam amino HIS57 

yang artinya asam amino histidin adalag ujung akhir dari rantai polipeptida.  

Ujung N dan C memiliki fungsi dan peran yang berbeda namun saling melengkapi 

dalam menentukan struktur, stabilitas, dan fungsi protein.  Ujung N memainkan 

peran dalam identifikasi protein dan proses awal (Yung and Giacca., 2020), 

sedangkan ujung C terlibat dalam modifikasi akhir, stabilitas, dan interaksi 

biologis protein (Ishmahdina dkk., 2021).  Berdasarkan validasi struktur X-Ray 

(Lampiran 1), protein 5KQG adalah Low Molecular Weight Phosphotyrosine 

Protein Phosphatase (LMW-PTP) pada struktur kristal ko-kristalisasi dengan      

2-(benzothiazol-2-ylamino)-2-oxo-1-phenylethanesulfonic acid. Struktur ini 

memiliki resolusi 1.50 Å dan tidak terdapat residu non-standar dalam rantai 

protein, DNA, atau RNA (Wang et al., 2016). 

 

2.11 Reseptor dan Ligan 

Bidang kajian bioinformatika yang sedang berkembang sekarang ini adalah 

molecular docking (penempatan molekul).  Molecular docking merupakan metode 

berbasis genetika yang dapat digunakan untuk mencari pola interaksi yang paling 

tepat dan melibatkan antara dua molekul, yaitu reseptor dan ligan.  Tujuannya 

adalah untuk memprediksi konformasi yang terikat dan afinitas pengikatan. 

(a)                                                             (b) 

Ujung N 

Ujung C 

http://www.rcsb.org/
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Prediksi pengikatan molekul kecil ke protein sangat penting secara praktis karena 

digunakan untuk memilah hasil virtual molekul mirip obat untuk mendapatkan 

petunjuk untuk pengembangan obat lebih lanjut (Zhao and Caflish, 2010).  

 

Ligan dapat diartikan sebagai molekul atau sebuah atom yang dapat berikatan 

dengan molekul protein penerima yang disebut sebagai reseptor.  Ligan adalah 

pemberi sinyal yang terikat pada daerah pengikatan protein target.  Pengikatan ini 

terjadi karena disebabkan adanya ikatan hidrogen, ikatan ion, dan gaya van der 

Waals (Lepailleur et al., 2014). 

 

Perkembangan teori kimia kimia dan metode komputasi modern dipadukan 

dengan teknologi komputer canggih mampu mensimulasikan proses ineraksi obat 

reseptor.  Prinsip dasarnya adalah mengekspresikan sifat-sifat geometri, 

konformasi dan elektronik dari molekul obat dan reseptor menjadi fungsi energi, 

meminimalkan fungsi energi akan didapatkan bentuk geometri yang optimal dan 

paling stabil yang mencerminkan kekuatan ikatan obat-reseptor.  Kekuatan ikatan 

obat reseptor inilah yang dapat mempresentasikan aktivitas biologis obat 

dinyatakan dengan docking score (Jaundoo et al., 2018).  

 

2.12 Penentuan Farmakokinetik Obat  

2.11.1 Lipinski Rule of Five  

Lipinski Rule of Five merupakan aturan praktis yang digunakan untuk 

memprediksi keaktifan suatu obat atau senyawa kimia ketika diberikan secara oral 

pada manusia.  Reseptor yang digunakan dalam penelitian berada dalam sel 

sehingga ligan harus memilliki kemampuan untuk menembus membran sel agar 

dapat berikatan dengan reseptor targetnya.  Lipinski Rule of Five akan membantu 

untuk menentukan sebuah molekul (ligan) memiliki kemampuan biovibilitas yang 

tinggi sehingga dapat berikatan dengan reseptornya (Ivanović et al., 2020).  

Adapun syarat yang harus dipenuhi sebagai kandidat obat (Lipinski, 2023) 

diantaranya yaitu :  
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a. Berat molekul kurang dari 500  

b. Memiliki tidak lebih dari 5 ikatan hidrogen donor  

c. Memiliki tidak lebih dari 10 ikatan hidrogen akseptor  

d. Nilai logP tidak lebih dari 5  

e. Molar refractivity berada pada rentang 40 sampai 130  

2.11.2 Pre-ADME 

Software ini mudah digunakan untuk mendapatkan informasi terkait kemampuan 

absorpsi, distribusi, metabolisme dan ekskresi (ADME).  Salah satu uji yang dapat 

16 dianalisis uji Pre-ADME adalah uji HIA (Human Intestinal Absorption), sel 

Caco-2, dan PPB (Plasma Protein Binding).  HIA merupakan salah satu uji yang 

digunakan untuk memprediksi potensi terabsorpsi suatu senyawa obat di dinding 

usus.  Sel Caco-2 merupakan model in vitro untuk mengetahui transport obat 

melalui epitel intestinal yang berasal dari adenocarcinoma kolon manusia yang 

memiliki jalur transportasi ganda.  Plasma protein binding (PPB) merupakan 

fraksi obat yang tersedia dalam bentuk bebas untuk didistribusikan ke berbagai 

jaringan.  Uji ini telah digunakan dalam bidang farmakologi untuk kepentingan 

mendesain ataupun mengoptimasi kandidat obat (Juan, 2020).  

 

2.11.3 Toksisitas  

Uji toksisitas dilakukan menggunakan software protox yang memberikan 

informasi mengenai bagaimana prediksi toksisitas senyawa uji yang akan menjadi 

kandidat obat.  Parameter yang dilihat pada protox adalah prediksi kelas toksisitas 

serta prediksi yang melibatkan hepatotoxicity, carcinogenicity, immunotoxicity, 

mutagenicity, dan cytotoxicity (Titiek B, 2018). 

 

2.12 Quantitative Structure and Activity Relationship (QSAR) 

Kimia komputasi merupakan salah satu cabang ilmu kimia yang sangat membantu 

dalam penelitian Quantitative Structure and Activity Relationship (QSAR) atau 

disebut juga sebagai Hubungan Kuantitatif Struktur dan Aktivitas (HKSA).  

QSAR adalah metode yang digunakan dalam fase pengembangan obat baru.  Hal 

ini berkaitan dengan perkembangan penemuan obat baru yang semakin efektif dan 
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efisien (Umma dkk., 2018).  Penelitian kimia dengan seperangkat komputer dapat 

menganalisis hubungan struktur kimia dengan aktivitas biologis suatu senyawa, 

sehingga penelitian zat baru lebih terencana dan mampu membentuk ilmu baru 

berupa kimia medisinal dan farmakologi molekular (Verma et al., 2010). 

 

QSAR dapat digunakan pada penentuan struktur dan aktivitas dari suatu senyawa 

karena parameter ini menghitung elektron valensi dari setiap atom-atom sehingga 

waktu analisis yang dilakukan relatif singkat.  Metode QSAR menggunakan 

pengolahan data perhitungan secara statistika (kuantitatif) sehingga dapat 

menentukan perbedaan antara aktivitas senyawa (Asmara dkk., 2015).  

Keuntungan yang diperoleh dengan menggunakan metode QSAR adalah 

mengoptimalkan aktivitas, geometri, dan reaktivitas sebelum senyawa disintesis 

secara eksperimental. Hal ini dapat meminimalisir waktu dan biaya yang mahal, 

sehingga dapat menghasilkan senyawa dengan aktivitas seperti yang diharapkan 

(Yeni dkk., 2018).  Persamaan QSAR atau HKSA yang digunakan berdasarkan 

pada parameter yang digunakan dibagi menjadi tiga metode, yaitu Metode Hanch, 

Metode Free-Wilson, dan Metode Comparative Molecular Field Analysis 

(CoMFA) (Asmara dkk., 2015). 

2.12.1 Metode Hanch 

Metode Hanch pertama kali ditemukan oleh Corwin Hanch.  Metode Hanch 

adalah sebuah pendekatan penelitian Hubungan Kuantitatif Struktur dan Aktivitas 

(HKSA) yang menghubungkan sifat fisikokimia dengan ktivitas biologisnya 

(Utomo et al., 2017).  Metode Hanch digunakan dalam desain obat dan 

toksikologi untuk membantu mengidentifikasi senyawa kimia dengan aktivitas 

biologis yang diinginkan atau menghindari senyawa dengan potensi efek samping 

yang merugikan.  Perkembangan Metode Hanch melibatkan analisis regresi, 

dimana berbagai parameter fisikokimia (seperti lipofilisitas, polaritas, dan volume 

molekul) digunakan sebagai variabel independen atau menggunakan beberapa 

parameter teoritis.  Parameter-parameter tersebut menerangkan harga aktivitas 

biologis dari senyawa tersebut digunakan sebagai variabel bebas (La Kilo et al., 

2021).   
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2.12.2 Metode Free-Wilson 

Metode Free-Wilson dikembangkan oleh Free dan Wilson.  Prinsip dasar Metode 

Free-Wilson adalah aktivitas biologis suatu senyawa dapat dinyatakan sebagai 

fungsi dari efek aditif dari substituen kimia yang berbeda pada struktur molekul 

dasarnya.  Metode Free-Wilson mengajukan model matematik yang memprediksi 

bahwa aktivitas biologis sama dengan jumlah sumbangan substituein ditambah 

aktivitas biologis senyawa induk (Verma et al., 2010). 

2.12.3 Metode Comparative Molecular Field Analysis (CoMFA) 

Comparative Molecular Field Analysis (CoMFA) adalah metode yang digunakan 

dalam penelitian hubungan kuantitatif struktur-aktivitas Quantitative Structure-

Activity Relationship (QSAR).  Metode ini dikembangkan oleh Cramer, Patterson, 

dan Bunce pada akhir 1980-an dan menjadi salah satu pendekatan paling populer 

dalam QSAR tiga dimensi (3D-QSAR).  CoMFA dapat digunakan dalam 

desainobat dan toksikologi sebagai identifikasi penting aktivitas inhibisi, 

merancang senyawa baru yang lebih efektif dengan toksisitas minimal, serta 

memahami inetraksi antara ligand an reseptor pada tingkat molekuler (Mauri, 

2006). 

2.13 Deskriptor 

Deskriptor adalah variabel yang menggambarkan berbagai aspek struktur molekul 

yang dapat digunakan untuk memprediksi aktivitas biologis atau sifat fisikokimia 

suatu senyawa.  Deskriptor ini merupakan dasar dari model HKSA karena 

memungkinkan perbandingan antara struktur kimia dan aktivitas biologis melalui 

analisis statistik.  Prediktor yang diperoleh adalah perhitungan berat atom, Highest 

Occupied Molecular Orbital (HOMO), Lowest Occupied Molecular Orbital 

(LOMO), polarisasi, volume molekul, dan refraktivitas molar (Muchtaridi, 2018).  

Jenis descriptor molekul terbagi atas tiga yaitu deskriptor hidrofobik, deskriptor 

elektronik, dan deskriptor sterik. 
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2.13.1 Deskriptor Hidrofobik 

Deskriptor hidrofobik adalah parameter yang digunakan dalam merancang 

struktur obat.  Parameter hidrofobik terkait dengan kelarutan obat dalam air, 

permeabilitas membaran, dan pemberian entropi.  Parameter yang sering 

digunakan dalam descriptor hidrofobik adalah koefisien partisi (Log P).  Log P 

merupakan salah satu descriptor hidrofobik yang paling umum digunakan dalam 

HKSA karena parameter ini mengukur distribusi senyawa antara dua fase yang 

tidak dapat bercampur; n-oktanol (fase lipofilik) dan air (fase hidrofilik).  Nilai 

Log P yang lebih tingi menunjukkan sifat hidrofobik yang lebih besar (Arba, 

2019). 

2.13.2 Deskriptor Elektronik 

Deskriptor elektronik menggambarkan sifat elektonik molekul yang dapat 

mempengaruhi interaksi dengan targer biologis.  Parameter-parameter yang 

digunakan dalam memprediksi aktivitas biologis senyawa berdasarkan struktur 

kimianya adalah momen dipol (μ), energi Highest Occupied Molecular Orbital 

(HOMO), energi  Lowest Occupied Molecular Orbital (LOMO), dan muatan atom 

parsial (Gramatica, 2017).   

Muatan atom parsial adalah muatan parsial pada setiap atom dalam molekul yang 

dihasilkan dari distribusi elektron.  Muatan atom parsial dapat mempengaruhi 

interaksi elektrostatik antara molekul dan target biologis, seperti ikatan hidrogen 

dan interaksi ionic (Lin F. Y et al., 2019). Momen dipol mengukur polaritas 

molekul sebagai hasil dari distribusi muatan dalam molekul.  Momen dipol yang 

tinggi biasanya menunjukkan adanya area polar dalam molekul yang bisa 

mempengaruhi kelarutan dan interaksi dengan target biologis (Dewi, 2020).  

HOMO menunjukkan kemampuan molekul untuk menyumbangkan elektron, 

sedangkan LUMO menunjukkan kemampuan molekul untuk menerima elektron. 

Perbedaan energi antara HOMO dan LUMO (band gap) dapat mengindikasikan 

reaktivitas kimia (Khamouli et al., 2022).   
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2.13.3 Deskriptor Sterik 

Deskriptor sterik adalah parameter yang menggambarkan ukuran, bentuk, dan 

distribusi ruang yang dapat mempengaruhi interaksi dengan target biologis.  

Deskriptor ini bertujuan memahami aspek fisik molekul mempengruhi aktivitas 

biologisnya.  Parameter yang biasa digunakan dalam deskriptor sterik meliputi 

refraktivitas molar (MR), volume molar (MV), dan volume Van der Waals 

(Veerasamy et al., 2021).   

Luas permukaan merupakan salah satu deskriptor dalam parameter sterik yang 

berhubungan dengan kapasitas ukuran dan luas permukaan sentuh molekul yang 

bertujuan untuk memudahkan suatu molekul senyawa ketika menembus membran 

biologis pada suatu makhluk hidup (Rakhman et al., 2019).  Refraktivitas molar 

adalah ukuran volume suatu atom yang menunjukkan ukuran dan bentuk suatu 

senyawa (Widiyanti et al., 2021).  Masa molekul adalah massa atau berat molekul 

yang berhubungan dengan massa jenis dan jari-jari atom suatu senyawa.  Panas 

pembentukan merupakan suatu energi yang dikeluarkan atau dibutuhkan untuk 

membutuhkan satu molekul senyawa, sehingga nilai panas pembentukan akan 

berpengaruh terhadap daya ikat dari suatu senyawa (Zain et al., 2021). 

2.14 Analisis QSAR/HKSA pada Senyawa Obat 

Analisis statistik yang sering digunakan dalam hubungan kuantitatif antara 

struktur dan aktivitas melalui parameter kimia-fisik adalah analisis regresi linier 

dan nonlinier.  Analisis regresi linier meliputi regresi linier sederhana, Principal 

Component Analysis (PCA), Partial Least Square (PLS), dan Multiple Linear 

Regression (MLR).  Sedangkan analisis regresi nonlinier meliputi Support Vector 

Machine (SVM), k-Nearest Neghbor (kNN), dan Artificial Neural Network 

(ANN).  Analisis regresi linier dapat dibagi menjadi regresi linier tunggal dengan 

satu variabel bebas dan regresi multilinier dengan lebih dari satu variabel bebas 

(Arba, 2019).  

Model persamaan dipilih berdasarkan prediktor terbaik yang memenuhi 

persyaratan statistik menggunakan parameter R, R², dan Fhitung/Ftabel.   
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Suatu struktur dikatakan berhasil bila model persamaan yang dihasilkan memiliki 

nilai R² yang tinggi mendekati 1, yang menunjukkan hubungan yang baik antar 

variabel. Prediktor terbaik yang memenuhi persyaratan statistik harus dipilih 

berdasarkan parameter seperti R, R², dan Fhitung/Ftabel. Validasi model juga penting, 

di mana nilai Z-SCORE yang melebihi 2.5 harus dieliminasi, dan analisis statistik 

dilakukan kembali untuk memastikan keakuratan model, namun nilai R dan R² 

hanya menunjukkan kelinearitasan antar variabel dan tidak memberikan ukuran 

prediksi dari suatu model persamaan, sehingga deskriptor lain juga perlu 

diperhatikan untuk memperoleh persamaan terbaik (Male dkk., 2018). 

 

  



 

 

 
 

III. METODE PENELITIAN 

3.1  Waktu dan Tempat  

Penelitian ini dilakukan pada Oktober 2023 s.d. April 2024 di Universitas 

Lampung.  

 

 

3.2  Alat dan Bahan 

Alat-alat yang digunakan dalam penelitian ini adalah perangkat keras dan 

perangkat lunak.  Perangkat keras yang digunakan adalah Laptop Acer series 

A14-31-C736 dengan spesifikasi Processor Intel Celeron N3350 Dual-Core, 

RAM 4.00 GB, dan Windows 10 64-bit Operating System.  Perangkat lunak yang 

digunakan adalah AutoDocks-Tools 1.5.6, Discovery Studio Visualizer 2021, 

MarvinSketch 5.2.5.1, HyperChem, dan SPSS Statistics. 

Bahan-bahan yang digunakan adalah struktur 3D dari protein 5KQG yang 

diperoleh dari (https://www.rcsb.org/), struktur 3D dari senyawa kompleks Fe(II)-

Cys, Zn(II)-Cys, Mn(II)-Cys, Mg(II)-Cys, dan Metformin (C4H11N5) sebagai 

senyawa pembanding. 

 

3.3 Prosedur Penelitian 

3.3.1 Preparasi Protein 5KQG 

Kompleks protein 5KQG dipisahkan antara makromolekul dan ligan dengan 

menggunakan program Discovery Studio Visualizer, kemudian dilakukan 

optimasi dengan penambahan atom hidrogen dan minimisasi energi. Hasil 

pemisahan tersebut disimpan dalam format (.pdb).  

https://www.rcsb.org/
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Adapun langkah-langkah pada penelitian ini telah dilakukan oleh (Annisa, 2023) 

dan dimodifikasi menjadi sebagai berikut : 

3.3.1.1 Pembuatan Folder Kerja 

Membuat folder kerja baru pada Documents > VALIDASI 5KQG.  Folder kerja 

tersebut kemudian dimasukan software dan file yang dibutuhkan, yaitu 

5KQG.pdb, autogrid4, dan autodock4. 

 

3.3.1.2 Preparasi Reseptor 5KQG 

Preparasi dilakukan menggunakan software Discovery Studio Visualizer (DSV) 

2021.  Buka software DSV, dimasukkan protein 5KQG.pdb (File > Open); dipilih 

file 5KQG.pdb yang terletak pada folder kerja, lalu klik “OK”.  Setelah protein 

dibuka pada DSV (Scripts > Visualization > Publication Quality), dilakukan 

preparasi reseptor dengan menghapus molekul air (Scripts > Visualization > Hide 

Waters).  Kemudian (Scripts > Visualization > Hide Ligands) untuk menyisakan 

reseptor dari protein 5KQG.  Simpan sebagai reseptor 5KQG.pdb (File > Save As 

> Reseptor 5KQG.pdb) pada folder kerja yang telah dibuat. 

 

3.3.1.3 Preparasi Ligan 5KQG 

Setelah selesai melakukan preparasi reseptor protein 5KQG, maka bersihkan 

kembali layar kerja (Edit > Select All > Delete).  Kemudian buka kembali 

5KQG.pdb pada folder kerja (File > Open); dipilih file 5KQG.pdb yang terletak 

pada folder kerja, lalu klik “OK”.  Setelah protein dibuka pada DSV (Scripts > 

Visualization > Publication Quality), dilakukan preparasi reseptor dengan 

menghapus molekul air (Scripts > Visualization > Hide Waters).  Kemudian 

(Scripts > Visualization > Hide Proteins) untuk menyisakan ligan dari protein 

5KQG. Simpan sebagai ligan 5KQG.pdb (File > Save As > Ligan 5KQG.pdb) 

pada folder kerja yang telah dibuat. 
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3.3.2 Preparasi Ligan 

Ligan atau senyawa yang digunakan dalam penelitian ini merupakan ligan dari 

[Fe(cys)2], [Zn(cys)2], [Mn(cys)2], dan [Mg(cys)2], dan struktur Metformin 

(C4H11N5).  Struktur 2D digambar menggunakan program MarvinSketch lalu 

disimpan dengan dengan format (.pdb).  

 

Adapun langkah-langkah yang dilakukan pada tahap ini adalah sebagai berikut 

(Hari, 2019): 

Buka software MarvinSketch lalu gambar struktur senyawa kompleks Fe(II)-Cys, 

Zn(II)-Cys, Mn(II)-Cys, Mg(II)-Cys, dan Metformin.  Setelah selesai membuat 

struktur (Structure > Clean 2D > Clean in 2D). Struktur 2D dilakukan optimasi 

protonation dengan metode Major Microspecies untuk mendapatkan struktur yang 

disesuaikan dengan pH darah (Tools > Prototonation > Major Microspecies > pH 

7,4 > OK), maka akan muncul keterangan license; lalu klik OK.  Struktur yang 

telah dioptimasi disimpan dalam file format .mrv dengan cara klik kanan struktur 

lalu Save As (type file; mrv).  Setelah berhasil disimpan, bersihkan layar kerja 

MarvinSketch (File > New > Clear Desk), lalu buka struktur yang sebelumnya 

telah disimpan dalam format .mrv (File > Open).   

 

Konformasi yang paling baik dapat ditentukan dengan metode conformers (Tools 

> Conformation > Conformers), lalu klik OK.  Hasil kerja lalu disimpan dalam 

folder dengan format .pdb (File > Save As ; type Protein Data Bank). 

 

3.3.3 Validasi Metode Docking 

Validasi metode molecular docking dilakukan dengan cara redocking antara ligan 

bawaan dari reseptor target yang diunduh (5KQG) dari situs bank data protein 

menggunakan perangkat lunak AutoDockTools.  Analisis yang digunakan untuk 

mengevaluasi hasil validasi yaitu nilai RMSD, situs pengikatan yang ditemukan 

dan parameter yang digunakan dianggap valid jika nilai Root Mean Square 

Deviation (RMSD) ≤ 2Å Adapun langkah-langkah pada tahap ini adalah sebagai 

berikut: 
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3.3.3.1 Preparasi Reseptor dan Ligan 

Sebelum membuka software AutoDockTools, salin terlebih dahulu alamat folder 

penyimpanan reseptor dan ligan, lalu dilanjutkan dengan buka AutoDockTools 

1.5.6 (File > References > Paste Alamat Folder > Set), apabila sudah selesai maka 

preparasi reseptor dan ligan dapat dilakukan.  Preparasi reseptor dimulai dengan 

(File > Read Molecule > pilih Reseptor.pdb); setelah reseptor masuk kedalam 

AutoDockTools (Edit > Charges > Add Charges > OK); lalu (Edit > Hydrogens > 

Add > Polar Only > OK); untuk menyimpan reseptor yang telah selesai 

dipreparasi (Grid > Macromolecule > Choose > Reseptor > Select Molecule); klik 

“OK” lalu simpan dengan format nama (.pdbqt) apabila preparasi reseptor telah 

selesai dilakukan (Edit > Delete > Delete All Molecule > Continue). 

 

Preparasi ligan dapat dilakukan dengan cara yang hampir sama denganr reseptor, 

(File > Read Molecule > pilih Ligan.pdb); setelah reseptor masuk kedalam 

AutoDockTools (Edit > Charges > Add Charges > OK); lalu (Edit > Hydrogens > 

Add > All Hydrogens > OK); (Edit > Hydrogens > Merge Non Polar); (Edit > 

Hydrogens > Delete > Delete Hydrogens > OK); (Ligand > Input > Choose > 

Ligand > Select molecule for AutoDock4) lalu klik “OK”, selanjutnya (Ligand > 

Torsion Tree > Detect Root); (Ligand > Torsion Tree > Choose Root); (Ligand > 

Torsion Tree > Choose Torsions) lalu klik “DONE”. Selanjutnya, (Ligand > 

Torsion Tree > Set Number of Torsions); untuk menyimpan ligan yang telah 

selesai dipreparasi (Ligand > Output > Save As PDBQT); klik “OK” lalu simpan 

dengan format nama (.pdbqt) 

 

3.3.3.2 Mengatur Gridbox 

Pengaturan grid box parameter dilakukan menggunakan AutoDocksTools-1.5.6.  

Koordinat grid box ditentukan berdasarkan koordinat ligan dari file reseptor yang 

digunakan pada saat validasi, kemudian dilakukan proses penambatan senyawa uji 

ligan terhadap reseptor yang telah divalidasi.   
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Tabel 1. Pengaturan grid center dan dimensi gridbox 

Gridbox 

 Center Dimensi (Å) 

Protein X Y Z X Y Z 

5KQG -1.773 11.122 1.318 40 40 40 

 

Adapun langkah-langkah yang dilakukan pada tahap ini adalah sebagai berikut: 

a. Menentukukan lokasi docking pada reseptor 

(Grid > Macromolecule > Open > Reseptor.pdbqt); klik “YES” 

(Grid > Set Map Types > Open Ligand > Ligan.pdbqt) 

(Grid > Macromolecule > Choose > Reseptor > Select Molecule); klik “YES” 

(Grid > Set Map Types > Choose Ligand > Ligand > Select Ligand) 

b. Menentukan ukuran Gridbox 

(Grid > Grid Box > Center > Cemter on ligand); lalu atur ukuran x, y, dan z 

(File > Close saving current) 

(Grid > Output > Save GPF); simpan file dalam format (.gpf) 

3.3.3.3. Running Docking 

Setelah semua pengaturan docking selesai, kemudian dilakukan running terhadap 

senyawa uji dengan menggunakan Autogrid4 dan Autodock4.  Proses docking 

dilakukan dengan menggunakan pengaturan terhadap beberapa parameter yang 

diatur seperti grid box (x = 40, y=40, z = 40), gridbox center (x= -0.549, y = -

0.647, z = -0.036), spacing = 0,375Å, dan number of runs (20), Number of Evals: 

Medium, dan Metode Algoritma: Lamarckian Genetic Algorithm yang dapat 

dilakukan secara langsung melalui program AutoDockTools.  Setelah running 

selesai akan dihasilkan output dengan format (.dlg) yang dapat dibuka dengan 

bantuan program Notepad++, kemudian dilihat parameter yang dihasilkan berupa 

(∆G dan Cluster) dan membandingkan hasil yang didapat satu dengan yang 

lainnya.  
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3.3.4 Analisis Hasil Docking dan Visualisasi 2D  

Hasil docking kemudian dianalisa dengan cara membuka jenis file (.dlg) pada 

folder kerja yang di dalamnya memuat informasi mengenai energi ikatan serta 

nilai RMSD dari berbagai konformasi yang telah dibuat.  Selain itu, hasil 

konformasi terbaik yang telah dipilih dan disimpan dalam format (.pdb) dianalisa 

menggunakan Discovery Studio Visualizer 2021, (Ligan interaction > show 2D 

diagram); maka akan muncul interaksi ikatan yang terjadi.  Parameter yang 

dianalisa ikatan hidrogen dan residu asam amino. 

3.3.5 Penentuan Farmakokinetik 

Penentuan farmakokinetik menggunakan situs website Lipinski Rule of Five, Pre-

ADME, dan Protox. Prediksi kandidat obat dilakukan menggunakan ligan 

senyawa uji pada simulasi docking (Hendriko, 2023).  

a. Prediksi Lipinski Rule of Five 

Ketik alamat website (www.scfbio-iitd.res.in/software/drugdesign/lipinski.jsp), 

input file dengan format (.pdb) lalu klik submit. 

b. Prediksi Pre-ADME 

Ketik alamat website (https://preadmet.webservice.bmdrc.org/), klik ADME 

Prediction > Gambar struktur 2D yang akan dianalisis > klik submit. 

c. Prediksi Protox  

Ketik alamat website (www.tox-new.charite.de/protox_II/), pilih Tox 

Prediction > masukan nama senyawa yang akan dianalisis > klik run.  

 

3.3.6 Pemodelan Quantitative Structure And Activity Relationship (QSAR) 

Prosedur penelitian ini telah dilakukan oleh (Taufiq, 2021) dan dimodifikasi 

menjadi sebagai berikut: 

3.3.6.1 Pemodelan Struktur 

Struktur senyawa yang digunakan pada penelitian ini digambar pada aplikasi 

MarvinSketch dan disimpan dalam file.  Pemodelan struktur yang dibuat 

selanjutnya dilakukan pemodelan menjadi struktur 3D dengan program 

HyperChem. 

http://www.scfbio-iitd.res.in/software/drugdesign/lipinski.jsp
https://preadmet.webservice.bmdrc.org/
http://www.tox-new.charite.de/protox_II/
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Buka software MarvinSketch > gambar senyawa yang akan diuji > klik Save As 

(format dalam bentuk .mol) 

Buka software HyperChem > klik display > pilih rendering > klik pada pilihan 

Ball and Cylinders. 

3.3.6.2 Optimasi Geometri Struktur 

Senyawa yang telah dibentuk 3D melalui pemodelan, selanjutnya dioptimasi 

dengan metode semiempiris Austin Model 1 (AM1) dengan algoritma Polar-

Ribiere gradient 0.01kkal/Å. 

Buka software HyperChem > klik menu setup > AM1, setelah klik OK pilih 

Compute > Geometry Optimazion > Polar-Ribiere > RMS gradient of : 0. 

01kkal/Å.  Hasil model molekul yang dioptimasi disimpan dengan cara > klik File 

> Star Log > Compute > Single Poin > Stop Log (file tersimpan dalam bentuk 

.mol). 

3.3.6.3 Perhitungan Deskriptor 

Descriptor dihitung dari struktur yang telah dioptimasi pada program HyperChem. 

Kalkulasi deksriptor yaitu dengan cara klik Compute > QSAR Properties > 

kemudian pilih descriptor yang akan dihitung, tekan OK untuk melihat hasil yang 

diperoleh. 

3.3.6.4 Analisis Statistik 

Analisis statistik berupa analisis korelasi dan analisis regresi multilinier yang 

dilakukan dengan program SPSS ® for Windows versi 29.0.2.0 dan Microsoft 

Office Excel @ 2010.  Variabel bebas yang digunakan yaitu log P, energi HOMO, 

energy LUMO, muatan bersih atom, energi hidrasi, polarisabilitas, energi total, 

momen dipol, luas permukaan perkiraan, luas permukaan jaringan, massa 

molekuler, refraktivitas molar, volume molekuler, dan panas pembentukan.  

Variabel terikat yang digunakan adalah log IC50.  

Buka software SPSS > input seluruh data deskriptor yang diperoleh dari program 

HyperChem > klik Analyze > pilih Correlate > Bivariate > input seluruh data 
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kedalam kolom variables.  Hasil yang muncul dijadikan data selanjutnya untuk 

membuat persamaan linier. 

Buka software SPSS > klik Analyze > pilih Regression > klik Linier > klik log 

IC50 sebagai Dependent dan variabel lain sebagai Independents > ubah Method : 

Backward > klik OK. 

Hasil yang diperoleh berupa deskriptor terpilih dengan persamaan QSAR dan nilai 

statistik seperti r, r
2
, SE, PRESS, dan F. 

3.3.6.5 Validasi dan Penetapan Model Persamaan QSAR 

Model atau variabel yang telah dipilih, kemudian divalidasi dengan menghitung 

nilai r, r
2
, SE, PRESS, dan F.  persamaan yang diterima harus memenuhi syarat 

nilai r
2
 dari 0.5 – 1, nilai Fhitung/Ftabel > 1, serta nilai PRESS dan SE yang paling 

terkecil. 

3.3.6.6 Desain Senyawa Baru 

Desain senyawa baru dilakukan dengan memperhatikan rumus persamaan QSAR 

yang diperoleh untuk dilakukan perhitungan nilai aktivitas prediksi antidiabetes. 
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- diunduh dari https://www.rcsb.org/  

- dihilangkan residu air dan native 

ligand dengan Discovery Studio 

Visualization 

- diunduh dari https://www.rcsb.org/ 

- dihilangkan residu air dan proteins 

dengan Discovery Studio 

Visualization 

- dibuat struktur 2D pada software 

MarvinSketch 

- Edit > Copy as SMILES (digunakan 

selanjutnya untuk parameter 

farmakokinetik) 

- disimpan dalam format (.mrv) 

- dioptimalisasi pada pH 7,4  

- disimpan sebagai format (.pdb) dalam  

3.3.7 Diagram Alir 

Adapun seluruh proses yang dilakukan dalam prosedur di atas dirangkum 

pada diagram alir sebagai berikut: 

1. Preparasi Reseptor 5KQG 

 

 

 

 

 

 

 

 

 

2. Preparasi Ligan 5KQG 

 

 

 

 

 

 

 

 

 

 

3. Preparasi Struktur Senyawa Kompleks 

 

 

 

 

 

 

 

 

 

Protein 5KQG 

Reseptor 5KQG.pdb 

Protein 5KQG 

Ligan 5KQG.pdb 

Struktur [Fe(cys)2], [Zn(cys)2], [Mn(cys)2], [Mg(cys)2] 

Ligan dengan format .mrv 

Ligan dengan format .pdb 

Gambar 4. Diagram Alir Penelitian (Preparasi Ligan 5KQG) 

Gambar 5. Diagram Alir (Preparasi Reseptor 5KQG) 

Gambar 6. Diagram Alir Penelitian (Preparasi Struktur Senyawa Kompleks) 
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- dilakukan docking dengan Reseptor 

5KQG.pdb pada software 

AutoDockTools 

- didapatkan nilai RMSD dan energi 

bebas Gibs 

- dianalisa pada konformasi terbaik 

dengan software AutoDockTools 

- divisualisasi dengan software 

Discovery Studio Visualization 

- dianalisa residu asam amino pada sisi 

aktif protein 

4. Docking dan Visualisasi 2D 

  
Ligan.pdb 

Hasil docking  

Format file .dlg 

Senyawa Kompleks .pdb 

Analisis Farmakokinetik 

Hasil 

Gambar 7. Diagram Alir Penelitian (Docking dan Visualisasi 2D) 
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5. Quantitative Structure And Activity Relationship 

  
Mulai Nilai deskriptor dari program 

HyperChem 

Training Sets 

Pemilihan dan 

perhitungan nilai 

deskriptor 

Membuat 

persamaan QSAR 

Pemilihan dan 

perhitungan nilai 

deskriptor 

Memvalidasi 

persamaan QSAR 

Persamaan QSAR 

Prediksi aktivitas 

antidiabetes Hasil 

Gambar 8. Diagram Alir Penelitian (Analisis QSAR) 
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BAB V PENUTUP 

5.1 Kesimpulan 

Berdasarkan penelitian yang sudah dilakukan, kesimpulan yang diperoleh sebagai 

berikut :  

1. Hasil molecular docking senyawa kompleks yang lebih baik dari 

Metformin (-2.77 Kkal/mol) dihasilkan oleh senyawa [Fe(cys)2] yaitu 

sebesar -5.08 Kkal/mol dengan jumlah kesamaan ikatan pada asam amino 

sisi aktif protein target 5KQG yaitu GLY14, TYR131, CYS17, ILE16, dan 

ARG18. 

2. Parameter farmakokinetik hasil uji [Fe(cys)2] pada Lipinski Rule of Five, 

Pre-ADME, dan ProTox-II telah terpenuhi keseluruhannya. 

3. Hasil prediksi aktivitas antidiabetes dari senyawa baru yang lebih 

menghambat yaitu [Fe(cys)2] dengan nilai Log IC50 perhitungan sebesar -

2.75 atau nilai IC50 perhitungan sebesar 0.02 μ M dibandingkan dengan 

dengan nilai Log IC50 eksperimen sebesar -1.64 atau nilai IC50 prediksi 

sebesar 30.58 μ M. 

4. Berdasarkan pemodelan keseluruhan senyawa kompleks yang dilakukan 

secara komputasi, diperoleh model terbaik yaitu [Fe(cys)2] sebagai kandidat 

antidiabetes. 

 

5.2 Saran 

Saran yang diberikan untuk pengembangan penelitian selanjutnya adalah 

melakukan sintesis senyawa kompleks [Fe(cys)2] secara in vitro untuk 

membuktikan penelitian komputasi yang telah dilakukan.
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